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What’s New in Version 4 

New features in SigmaXL Version 4.21 include: 
 

• Improved Histograms: X axis numeric labels now align with bin tick marks. 
 

• Control Charts (SigmaXL > Control Charts > “Tests for Special Causes” Defaults): 
o Set defaults to apply any or all of Tests 1-8. 
o Test 2 can be set to 7, 8, or 9 points in a row on same side of CL. 

 
• Change Time Format to Seconds (SigmaXL > Data Manipulation > Data Preparation > 

Change Time Format to Seconds) will calculate the number of seconds from time format. 
For example 0:00:00 converts to 0 seconds; 23:59:59 converts to 86399 seconds. 
 

• Relocated “Clear Saved Defaults” Menu (SigmaXL > Help > Clear Saved Defaults).  
“Clear Saved Defaults” was previously in the Data Manipulation menu. 

 
New features in SigmaXL Version 4.2 include: 
 

• Normal Probability Plot (SigmaXL > Graphical Tools > Normal Probability Plots): 
o 95% Confidence Intervals to ease interpretation of normality/non-normality. 

 
• Scatter Plots (SigmaXL > Graphical Tools > Scatter Plots): 

o Optional 95% Confidence Intervals added to Trendline. This provides a confidence 
interval for the mean of predicted Ŷ. 

o Optional 95% Prediction Intervals added to Trendline. This provides a confidence 
interval for the individual values of predicted Ŷ. 

 
• Binary Logistic Regression (SigmaXL > Statistical Tools > Regression > Binary Logistic 

Regression): 
o Categorical (discrete) predictors can now be included in the model in addition to 

continuous predictors.  
o Wald Estimates (p-values) for categorical predictors. 
o Hosmer-Lemeshow goodness of fit test. 
o Measures of Association: Concordant/Discordant, Goodman-Kruskal Gamma, 

Somers' D and Kendall's Tau-a. 
 

• Ordinal Logistic Regression (SigmaXL > Statistical Tools > Regression > Ordinal 
Logistic Regression): 

o Categorical (discrete) predictors can now be included in the model in addition to 
continuous predictors.  

o Wald Estimates (p-values) for categorical predictors. 
o Measures of Association: Concordant/Discordant, Goodman-Kruskal Gamma, 

Somers' D and Kendall's Tau-a. 
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New features in SigmaXL Version 4.1 include: 
 

• Random Subset (SigmaXL > Data Manipulation > Random Subset): 
o Create a random subset of a worksheet with user specified number of rows. 
o Option to keep the subset in original order or randomly sort. 
o This feature is useful for data collection to ensure a random sample, e.g. given a list 

of transaction numbers select a random sample of 30 transactions. 
 

• Box-Cox Power Transformation (SigmaXL > Data Manipulation > Box-Cox 
Transformation or SigmaXL > Control Charts > Box-Cox Transformation): 

o Apply automatic power transformations to data (Y^lambda, where lambda varies 
from -5 to +5). 

o This is used to convert non-normal data to normal. 
o Select rounded or optimal lambda to store transformed data. Rounded is typically 

preferred since it will result in a more “intuitive” transformation such as Ln(Y) or 
SQRT(Y). 

o Anderson-Darling normality test is applied to the transformed data so that you can 
immediately see whether or not the final transformation results in normal data. 

o Option to not store transformed data if Lambda=1 falls with the 95% confidence 
interval. 

o Option to not store the transformed data if it is not-normal, i.e. the resulting Anderson 
Darling Test p-value < .05. 
 

• Gage R&R Study (SigmaXL > Templates & Calculators > Gage R&R Study (MSA)): 
o Added Variance Components and Percent Contribution to template report. 

 
• Attribute Gage R&R (SigmaXL > Templates & Calculators > Attribute Gage R&R 

(MSA)) : 
o Added Cohen’s Kappa to template report. 

 
• Equal Variance Tests (SigmaXL > Statistical tools > Equal Variance Tests): 

o Bartlett’s Test – multiple comparison of variances; used when all groups have normal 
data. 

o Levene’s Test – multiple comparison of variances; used when one or more groups 
have non-normal data. 

o Welch’s ANOVA – multiple comparison of means; equivalent to One-Way ANOVA, 
but used when the assumption of equal variances is not met. 
 

• Binary Logistic Regression (SigmaXL > Statistical Tools > Regression > Binary Logistic 
Regression): 

o Powerful and user-friendly binary logistic regression. 
o Use when the response is binary (e.g. 0/1 or Pass/Fail). 
o Report includes a calculator to predict the response event probability for a given set 

of input X values. 
o Model summary and goodness of fit tests including Likelihood Ratio Chi-Square, 

Pseudo R-Square, Pearson Residuals Chi-Square, Deviance Residuals Chi-Square, 
Observed and Predicted Outcomes – Percent Correctly Predicted. 
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o Stored data includes Event Probabilities, Predicted Outcome, Observed-Predicted, 
Pearson Residuals, Standardized Pearson Residuals, and Deviance Residuals. 
 

• Ordinal Logistic Regression (SigmaXL > Statistical Tools > Regression > Ordinal 
Logistic Regression): 

o Powerful and user-friendly ordinal logistic regression. 
o Use when the response is ordinal (e.g. survey response 1,2,3,4,5). 
o Report includes a calculator to predict all response event probabilities for a given set 

of input X values. 
o Model summary and goodness of fit tests including Likelihood Ratio Chi-Square, 

Pseudo R-Square, Pearson Residuals Chi-Square, Deviance Residuals Chi-Square, 
Observed and Predicted Outcomes – Percent Correctly Predicted. 

o Stored data includes Event Probabilities and Predicted Outcome. 
 

• Control Chart Advanced Limit Options (SigmaXL > Control Charts, Advanced Limit 
Options): 

o Calculate Control Limits with user specified subgroups. 
o Calculate Control Limits with historical groups. This results in split limits and is 

especially useful to demonstrate before improvement versus after improvement. 
 
New features in SigmaXL Version 4.0 include: 
 

• Recall SigmaXL Dialog   
o This will activate the last data worksheet and recall the last dialog, making it very 

easy to do repetitive analysis. 
o To access, click menu: Recall SigmaXL Dialog or Hot Key F3 or Alt-R. 
o This can also be accessed by clicking SigmaXL > Help > Hot Keys > Recall 

SigmaXL Dialog. 
 

• Activate Last Worksheet 
o This will activate the last data worksheet used without recalling the dialog.  
o To access, press hot key F4. 
o This can also be accessed by clicking SigmaXL > Help > Hot Keys > Activate Last 

Sheet. 
 

• Normal Random Number Generator (SigmaXL > Data Manipulation > Normal Random 
Data) works with Recall SigmaXL Dialog (F3) to append columns to the current Normal 
Random Data worksheet. Column headings are automatically created with Mean and 
Standard Deviation values (e.g. 1: Mean = 0; Stdev = 1). 
 

• Change Text Data Format to Numeric (SigmaXL > Data Manipulation > Data 
Preparation > Change Text Data Format to Numeric) will convert data that represents 
numeric values but is currently in text format.  This sometimes occurs when importing data 
into Excel from another application or text file.    
 

• Run Chart (SigmaXL > Graphical Tools > Run Chart) now includes a Nonparametric 
Runs Test.  This allows you to test for Clustering, Mixtures, Lack of Randomness, Trends 
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and Oscillation. 
 

• One-Way ANOVA & Means Matrix (SigmaXL > Statistical Tools > One-Way ANOVA & 
Means Matrix) now includes an optional report for Sums-of-Squares (SS) details. 
 

• Nonparametric Tests (SigmaXL > Statistical Tools > Nonparametric Tests): 
o 1 Sample Sign 
o 1 Sample Wilcoxon 
o 2 Sample Mann-Whitney 
o Kruskal-Wallis Median Test (includes graph of Group Medians and 95% Median 

Confidence Intervals) 
o Mood’s Median Test (includes graph of Group Medians and 95% Median Confidence 

Intervals) 
o Runs Test (test for Clustering, Mixtures, Lack of Randomness, Trends and 

Oscillation). 
• Power and Sample Size Calculators (SigmaXL > Statistical Tools > Power & Sample Size 

Calculators) for: 
o 1 Sample t-Test 
o 2 Sample t-Test 
o One-Way ANOVA 
o 1 Proportion Test 
o 2 Proportions Test 
The Power and Sample Size Calculators allow you to solve for Power (1 – Beta), Sample 
Size, or Difference (specify two, solve for the third).  If used with Recall SigmaXL 
Dialog (F3) the results will be appended to the current worksheet.  Excel graphs can then 
be generated to show the relationships between Power, Sample Size, and Difference. 
 

• Power and Sample Size with Worksheets (SigmaXL > Statistical Tools > Power & Sample 
with Worksheets) for: 

o 1 Sample t-Test 
o 2 Sample t-Test 
o One-Way ANOVA 
o 1 Proportion Test 
o 2 Proportions Test 
The Power and Sample Size with Worksheets allows you to solve for Power (1 – Beta), 
Sample Size, or Difference (specify two, solve for the third).  You must have a worksheet 
with Power, Sample Size, or Difference values along with other inputs such as Standard 
Deviation and Alpha.  This is particularly useful to generate Excel graphs to show the 
relationships between Power, Sample Size, and Difference.  
 

• Power and Sample Size Chart (SigmaXL > Statistical Tools > Power & Sample Chart) is 
used with the Power & Sample Size Calculator or Worksheet to quickly create a graph 
showing the relationship between Power, Sample Size and Difference. 
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Installation Notes  

1. This installation procedure assumes that you have administrator rights to install software on 
your computer.  Please uninstall any earlier (or trial) versions of SigmaXL. 
 

2. If you are installing from a CD, the SigmaXL installer will run automatically.  If you 
downloaded SigmaXL, please double-click on the file SigmaXL_Setup.exe. 
 

3. We recommend that you accept all defaults during the install.  Enter User Name, Company 
Name, and Serial Number.  If this is a trial version, a serial number is not required for 
installation.  If you purchased SigmaXL as a download, you received an order confirmation 
by e-mail.  The order number is also your serial number.  If you purchased a CD, the serial 
number is on the inside cover behind the CD.  If you are unable to locate your serial number 
please call SigmaXL at 1-866-475-2124 (toll free in North America) or 1-416-236-5877. 
 

4. Setup type should be “typical”.  The installer will automatically create a desktop shortcut to 
SigmaXL. 
 

5. To activate SigmaXL double-click on the SigmaXL desktop icon, or click Start > Programs > 
SigmaXL > SigmaXL. 

 
6. The following dialog box will appear on first use of SigmaXL: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Check “Always trust macros from this source” as shown below. SigmaXL is digitally signed 
by Verisign.  Users can be confident that the code has not been altered or corrupted since it 
was created and signed.   
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8. Click “Enable Macros.”  Note that the prompt to enable macros will never be given again, 
unless SigmaXL is removed from the list of Trusted Sources.  This list is available in Tools > 
Macro > Security. Click Trusted Sources. 
 

9. An alternative approach to starting Excel add-ins, known as “demand load”, starts the add-in 
automatically whenever Excel starts.  This is NOT recommended due to potential software 
conflicts. 
 

10. SigmaXL is added to Excel’s menu system as shown: 
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Clear Saved Defaults

“Clear Saved Defaults” will reset all saved defaults such as Pareto and Multi-Vari Chart settings, 
saved control limits, and dialog box settings.  All settings are restored to the original installation 
defaults. 

Click SigmaXL > Help > Clear Saved Defaults.  A warning message is given prior to clearing saved 
defaults. 
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SigmaXL® System Requirements 
  

Minimum System Requirements: 

Computer and processor: Personal computer with an Intel Pentium 233-MHz or faster processor 
(Pentium III recommended) 

Memory: 256 megabytes (MB) of RAM or greater 

Hard disk: 30 MB of available hard-disk space  

Drive: CD-ROM or DVD drive 

Display:  Super VGA (800 × 600) or higher-resolution monitor  

Operating system: Microsoft Windows® 2000 with Service Pack 3 (SP3), Windows XP, or later  
 
Microsoft Excel version: Excel 2000 with Service Pack 3 (SP3), Excel XP, or Excel 2003. 

 

 



SigmaXL: Installation Notes, Getting Help and Product Registration 

17 

Getting Help and Product Registration 
 

To access the help system, please click SigmaXL > Help > Help.   
 
Technical support is available by phone at 1-866-475-2124 (toll-free in North America) or 1-416-
236-5877 or e-mail support@sigmaxl.com. 
 
Please note that registered users obtain free technical support and upgrades for one year from date of 
purchase. 
 
To register by web, simply click SigmaXL > Help > Register SigmaXL. 

mailto:support@sigmaxl.com
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Introduction 

SigmaXL 4.21 is a powerful but easy to use Excel Add-In that will enable you to Measure, Analyze, 
Improve and Control your service, transactional, and manufacturing processes.  This is the perfect 
cost effective tool for Six Sigma Green Belts and Black Belts, Quality and Business Professionals, 
Engineers, and Managers. 
 
SigmaXL will help you in your problem solving and process improvement efforts by enabling you to 
easily slice and dice your data, quickly separating the “vital few” factors from the “trivial many”.  
This tool will also help you to identify and validate root causes and sources of variation, which then 
helps to ensure that you develop permanent corrective actions and/or improvements. 
 

The Y=f(X) Model  
 
SigmaXL utilizes the “Y=f(X)” model in its dialog boxes.  Y denotes a key process output metric; X 
denotes a key process input metric.  This process is shown pictorially as: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The mathematical expression Y = f(X) denotes that the variable Y is a function of X.   Y represents 
the key process output metric(s), X denotes the key process input metric(s). Another way to view 
this is that Y is the effect of interest, and X is the cause. Examples of Y are Yield, Customer 
Satisfaction, and Order to Delivery Time.  Examples of X are Raw Material Type, Responsiveness to 
Calls, and Location.  The key is to figure out which X’s from among many possible are the key X’s 
and to what extent do they impact the Y’s of interest.  Solutions and improvements then focus on 
those key X’s. 

ProcessX Y
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Data Types: Continuous Versus Discrete 
 
X and Y metrics can each be continuous or discrete.   A continuous measure will have readings on a 
continuous scale where a mid-point has meaning.  For example, in a customer satisfaction survey 
using a 1 to 5 score, the value 3.5 has meaning.  Other examples of continuous measures include 
cycle time, thickness, and weight.  A discrete measure is categorical in nature.  If we have Customer 
Types 1, 2, and 3, customer type 1.5 has no meaning.  Other examples of discrete measures include 
defect counts and number of customer complaints. 
 
It is possible to have various combinations of discrete/continuous X’s and discrete/continuous Y’s.   
Some examples are given below: 
 
Examples of Discrete X and Discrete Y 
 

• X = Customer Type, Y = Number of Complaints 
 

• X = Product Type, Y = Number of Defects 
 

• X = Day Shift vs. Night Shift, Y = Proportion of Defective Units 
 
Examples of Discrete X and Continuous Y 
 

• X = Customer Type, Y = Customer Satisfaction (1-5) 
 

• X = Before Improvement vs. After Improvement, Y = Customer Satisfaction (1-5) 
 

• X = Location, Y = Order to Delivery Time 
 
Examples of Continuous X and Discrete Y 

 
• X = Responsiveness to Calls (1-5), Y = Number of Complaints 
 
• X = Process Temperature, Y = Number of Defects 

 
Examples of Continuous X and Continuous Y 
 

• X = Responsiveness to Calls (1-5), Y = Customer Satisfaction (1-5) 
 
• X = Amount of Loan ($), Y = Cycle Time (Loan Application to Approval) 

 
 
Note that in SigmaXL, a discrete X can be text or numeric, but a continuous X must be numeric.  
Y’s must be numeric. If Y is discrete, count data will be required.  If the data of interest is discrete 
text, it should be referenced as X1 and SigmaXL will automatically search through the text data to 
obtain a count (applicable for Pareto, Chi-Square and EZ-Pivot tools). 
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Stacked Data Column Format versus Unstacked Multiple 
Column Format 
 
SigmaXL can accommodate two data formats: stacked column and unstacked multiple column.  The 
stacked column format has an X column also referred to as the “Group Category” column and a Y 
column that contains the data of interest.  The following is an example of data in stacked column 
format, with three unique groups of Customer Type: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If the data is in unstacked multiple column format, each unique group of X corresponds to a different 
column.  The above data is now shown in unstacked format with customer satisfaction scores for 
each customer type in separate columns: 
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SigmaXL: Measure Phase Tools 

Part A - Basic Data Manipulation  

Introduction to Basic Data Manipulation

Open Customer Data.xls. This data is in “stacked” column format.  This format is highly 
recommended for use with SigmaXL.  Note that all pertinent information is provided in each record 
(row).  Also note that only one row is used for column headings (labels) and there are no blank rows 
or columns.  Each column contains a consistent format of either numeric, text, or date.  This is also 
the data format used by other Statistical software packages such as Minitab and JMP. 
 

 

 

Note that Loyalty, Overall Satisfaction, Responsive to Calls, Ease of Communications, and Staff 
Knowledge were obtained from surveys.  A Likert scale of 1 to 5 was used, with 1 being very 
dissatisfied, and 5 very satisfied.  Survey results were averaged to obtain non-integer results. 

Category Subset

1. Click SigmaXL > Data Manipulation > Category Subset 

2. If you are working with a portion of a dataset, specify the appropriate range, otherwise check  
“Use Entire Data Table” 
 
 
 
 
 
 
 
 
 

3. Check “Use Entire Data Table”. Click Next. 
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4. Select Customer Type, 1, >> as shown: 

 

 

 

 
 
 

 

5. Click OK 

A new subset worksheet is created containing only Customer Type 1. 
Note:  We could have chosen more than one Customer Type and had the option to create a 
subset which included or excluded these Customer Types. 

Random Subset

1. Click Sheet 1 Tab of Customer Data.xls  

2. Click SigmaXL > Data Manipulation > Random Subset. 

3. Ensure that the entire data table is selected. If not, check “Use Entire Data Table”. Click 
Next. 

4. Enter “Number of Rows in Random Subset” as 30. The default Sort selection is Original 
Order. 
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5. Click OK.  A new worksheet is created that contains a random subset of 30 rows.    
This feature is useful for data collection to ensure a random sample, e.g. given a list of 
transaction numbers select a random sample of 30 transactions. 

Numerical Subset

1. Click Sheet 1 Tab of Customer Data.xls  

2. Click SigmaXL > Data Manipulation > Numerical Subset 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

4. Select Overall Satisfaction, >=, Enter Value “4” 
 

 

 
 

 

 

 
 

5. Click OK 
A new subset worksheet is created containing only those rows with Overall Satisfaction >= 4. 

Date Subset

1. Click Sheet 1 Tab of Customer Data.xls  

2. Click SigmaXL > Data Manipulation > Date Subset 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 
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4. Select Order Date, select 1/8/2001, click Start Date, select 1/12/2001, click End Date  
 
 
 
 
 
 
 
 
 

5. Click OK 
A new subset worksheet is created containing only those rows with Order Date between 
1/9/2001 to 1/12/2001. 
 

Stack Columns

1. Open Customer Satisfaction Unstacked.xls  

2. Click SigmaXL > Data Manipulation > Stack Columns 

3. Check  “Use Entire Data Table”, click Next 

4. Shift Click on Overall Satisfaction_3 to highlight all three column names as shown: 
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5. Select the Columns (>>).  Enter the Stacked Data (Y) Column Name as “Overall 
Satisfaction”.  Enter the Category (X) Column Name as “Customer Type”. 
 
 
 
 
 
 
 
 

6. Note that a selected column may be removed by highlighting and double-clicking or clicking 
the Remove button.  

7. Click OK. Shown is the resulting stacked column format:  
 
 
 
 
 
 
 
 
 
 
 
 

8. Data that is in stacked column format can be unstacked using Data Manipulation > Unstack 
Column. 

Normal Random Data

The normal random data generator is used to produce normal random data.  Column headings are 
automatically created with Mean and Standard Deviation values (e.g. 1: Mean = 0; Stdev = 1).  This 
utility works with Recall SigmaXL Dialog (F3) to append columns to the current Normal Random 
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Data worksheet. An example is shown in Measure Phase Tools, Part F – Normal Probability 
Plots. 

Box-Cox Transformation
 
This tool is used to convert non-normal data to normal by applying a power transformation.  
Examples of use are given in Measure Phase Tools, Part H – Process Capability for Non-Normal 
Data and Control Phase Tools, Part A – Individuals Charts for Non-Normal Data. 

Data Preparation – Remove Blank Rows and Columns 

This data preparation utility is provided as a convenient way to prepare data for analysis by deleting 
any empty rows and/or columns. 

1. Open Customer Data.xls. Click Sheet 1 Tab. 

2. Insert a new column in B; Click column B heading, click Insert > Columns. 

3. Insert a new row in row 2. Click row 2 label, click Insert > Rows as shown: 
 
 
 
 
 
 
 
 
 
 
 

4. This is now an example of a data set that requires deletion of empty rows and columns. Click 
SigmaXL > Data Manipulation > Data Preparation > Remove Blank Rows and Columns. 

5. Check Delete Empty Rows and Delete Empty Columns. 
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6. Click OK.  A warning message is given prior to the deletion step. 
 
 
 
 

7. Click Yes. The empty rows and columns are deleted automatically. 
 
 
 
 
 
 
 
 
 
 

Data Preparation – Change Text Data Format to Numeric 

This data preparation utility will convert data that represents numeric values but is currently in text 
format.  This sometimes occurs when importing data into Excel from another application or text file. 

Data Preparation – Change Time Format to Seconds 

Change Time Format to Seconds will calculate the number of seconds from time format. For 
example 0:00:00 converts to 0 seconds; 23:59:59 converts to 86399 seconds.
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Recall SigmaXL Dialog 

Recall SigmaXL Dialog is used to activate the last data worksheet and recall the last dialog, making 
it very easy to do repetitive analysis.  To access, click the top level menu “Recall SigmaXL Dialog” 
located to the right of the SigmaXL menu: 
 
 
 
Alternatively you can use the Hot Key F3 or Alt-R.  This feature can also be accessed by clicking 
SigmaXL > Help > Hot Keys > Recall SigmaXL Dialog. 

Activate Last Worksheet 

Activate Last Worksheet is used to activate the last data worksheet without recalling the dialog. To 
access, press hot key F4.  This feature can also be accessed by clicking SigmaXL > Help > Hot Keys 
> Activate Last Sheet. 
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Part B – Templates & Calculators  

Introduction to Templates & Calculators

All SigmaXL generated templates and calculators (except Gage R&R and DOE) are stand alone 
worksheets; they do not require that SigmaXL be active to be used.  Simply enter the inputs and 
resulting outputs are produced immediately.  If the template does not automatically perform the 
calculations, click Tools > Options, select Calculation, Automatic, and click OK.  Templates and 
Calculators are protected worksheets by default, but this may be modified by clicking Tools > 
Protection > Unprotect Sheet.  Gage R&R is password protected, so it cannot be unprotected. Click 
SigmaXL > Templates & Calculators to access these templates and calculators: 

• Cause & Effect (XY) Matrix 

• Failure Mode & Effects Analysis (FMEA) 

• Sample Size – Discrete 

• Sample Size – Continuous 

• Gage R&R Study (MSA) 

• Gage R&R: Multi-Vari & X-bar R Charts 

• Attribute Gage R&R (MSA) 

• Process Sigma – Discrete 

• Process Sigma – Continuous 

• Process Capability 

• Process Capability & Confidence Intervals 

• Standard Deviation Confidence Interval 

• 1 Proportion Confidence Interval 

• 2 Proportions Test 
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Cause & Effect (XY) Matrix – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named C&E Matrix.  
This is a simple Cause and Effect Matrix example for a Call Center.  

 
 
 
 
 
 
 
 
Notes for use of the Cause and Effect Matrix template, also known as the XY Matrix: 

1. Weight the Output Variables (Y's) on a scale of 1 to 10 with 10 indicating most important to 
the Customer. 

2. For Root Cause Analysis, assign the association/effect multiplier score for each X to Y using 
a scale of 0, 1, 3, 9, where 0 = None, 1 = Weak, 3 = Moderate, and 9 = Strong.  Initially this 
assignment will likely be a team subjective assessment. Data should be collected and the 
degree of association should be validated with Graphical and Statistical Tools. 

3. For Project Selection or Solution Selection, assign the association multiplier score for each X 
to Y using a scale of 1 to 10, with 10 indicating strong association. 
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Failure Mode & Effects Analysis (FMEA) – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named FMEA.  This 
is a simple Failure Mode and Effects example for Stocking Inventory.  
 
 
 
 
 
 
 
 
 
 
Recommended scales for Severity, Occurrence, and Detection are shown below: 
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Sample Size – Discrete Calculator Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Sample Size 
Discrete.   
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Sample Size – Discrete Calculator: 

1. P is estimate of proportion for outcome of interest.  Use P = 0.5 if unknown. 

2. Delta is desired proportion margin of error.  Enter as the half-width, i.e. if the desired margin 
of error is +/- 3%, enter 0.03.  

3. The margin of error is a 95% confidence interval. 

4. Enter population size N to adjust for small populations (N < 10000). 

5. np should be >= 5. If necessary, reduce delta to adjust. 
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Sample Size – Continuous Calculator Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Sample Size 
Continuous.   
 
 
 
 
 
 
 
 
 
 
Notes for use of the Sample Size – Continuous Calculator: 

1. Delta uses the same units as the standard deviation.  Enter as the half-width, i.e., if the 
desired margin of error is +/- 0.25, enter 0.25.  

2. The margin of error is a 95% confidence interval. 

3. Enter (optional) population size N to adjust for small populations (N < 1000). 
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Gage R&R Study (MSA) – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Gage R&R.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Gage R&R Template: 

1. Recommended study includes 10 Parts, 3 Operators and 3 Repeats.  The template 
calculations will work with a minimum of 2 Operators, 2 Parts and 2 Repeats.  The data 
should be balanced with each operator measuring the same number of parts and the same 
number of repeats. 

2. Enter process Upper Specification Limit (USL) and Lower Specification Limit (LSL) in the 
Process Tolerance window.  This is used to determine the % Tolerance metrics. If  the 
specification is single-sided, leave both entries blank. 

3. The default StDev multiplier is 6.  Change this to 5.15 if AIAG convention is being used. 

4. The cells shaded in light blue highlight the critical metrics Gage R&R % Total Variation 
(also known as %R&R) and %Tolerance. ( < 10% = Good Measurement System; > 30% = 
Bad Measurement System). 
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Gage R&R: Multi-Vari & X-bar R Charts – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheets named Gage R&R - 
Multi-Vari and Gage R&R – X-Bar R. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Gage R&R: Multi-Vari & X-bar R Charts: 
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1. The Gage R&R Multi-Vari and X-bar & R charts can only be generated if a Gage R&R 
template has been completed and is the active worksheet.  Select the Gage R&R worksheet 
and click SigmaXL > Templates & Calculators > Gage R&R: Multi-Vari & X-Bar R 
Charts to create the above charts. 

2. The Multi-Vari chart shows each Part as a separate graph.  Each Operator’s response 
readings are denoted as a vertical line with the top tick corresponding to the Maximum value, 
bottom tick is the Minimum, and the middle tick is the Mean.  The horizontal line across 
each graph is the overall average for each part. 

3. When interpreting the X-bar and R chart for a Gage R&R study, it is desirable that the X-bar 
chart be out-of-control, and the Range chart be in-control.  The control limits are derived 
from within Operator repeatability. 
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Attribute Gage R&R (MSA) – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Attribute 
MSA. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Attribute Gage R&R (MSA) Template: 

1. Attribute Gage R&R is also known as Attribute Agreement Analysis. 

2. Recommend for study: 3 Appraisers, 2 Repeats, Minimum of 10 Good Parts and 10 Bad 
Parts. The data should be balanced with each appraiser evaluating the same number of parts 
and the same number of repeats. 

3. Specify the Good Part or Unit as “G” or other appropriate text (“P”, “Y”, etc.).  Specify the 
Bad Part or Unit as “NG” or other appropriate text (“F”, “N”, etc.).  Be careful to avoid 
typing or spelling errors when entering the results.  A space accidentally inserted after a 
character will be treated as a different value leading to incorrect results. 
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Process Sigma Calculator – Discrete Data Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Process 
Sigma Discrete.   
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Process Sigma Calculator for Discrete Data: 

1. Total number of defects should include defects made and later fixed. 

2. Sigma level incorporates 1.5 sigma shift. 

3. Sample size should be large enough to observe 5 defects. P is estimate of proportion for 
outcome of interest.  Use P = 0.5 if unknown. 
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Process Sigma Calculator – Continuous Data Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Process 
Sigma Continuous.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Process Sigma Calculator for Continuous Data: 

1. This calculator assumes that the Mean and Standard Deviation are computed from data that is 
normally distributed. 

2. Sigma Level incorporates a 1.5 sigma shift. 
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Process Capability Indices Calculator – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Capability 
Indices.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Process Capability Indices Calculator: 

1. This calculator assumes that the Mean and Standard Deviation are computed from data that is 
normally distributed. 

2. Reports Cp, Cpk if entered S is Within or Short Term (using a control chart). 

3. Reports Pp, Ppk if entered S is Overall or Long Term. 
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Process Capability & Confidence Intervals Calculator – 
Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named Capability 
Indices & CI.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notes for use of the Process Capability Indices Calculator: 

1. This calculator assumes that the Mean and Standard Deviation are computed from data that is 
normally distributed. 

2. Reports Cp, Cpk if entered S is Within or Short Term (using a control chart). 

3. Reports Pp, Ppk if entered S is Overall or Long Term. 
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Standard Deviation Confidence Interval Calculator – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named CI Sigma.   
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One Proportion Confidence Interval Calculator – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named 1 Proportion 
CI.   
 
 
 
 
 
 
 
 
 
 
 
 
 

Two Proportions Test Calculator – Example 

Open the file Template & Calculator Examples.xls.  Click on the worksheet named 2 Proportions 
Test.   
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Part C – Descriptive/Summary Statistics 

Descriptive Statistics 

1. Open Customer Data.xls. Click Sheet 1 Tab. 

2. Click SigmaXL > Statistical Tools > Descriptive Statistics 

3. Check  “Use Entire Data Table”, click Next 

4. Select Overall Satisfaction, click Numeric Data Variables (Y) >>. Select Customer Type, 
click Group Category (X1) >> as shown: 
 
 
 
 
 
 
 
 
 
 

5. Click OK 

6. Descriptive Statistics are given for Customer Satisfaction broken out by Customer Type: 
 
 
 
 
 
 
Which Customer Type has the highest satisfaction score? Clearly Type 2. However we have 
to be careful concluding that there is a significant difference in satisfaction solely by looking 
at the Means.  In the Analyze Phase we will run tests of hypothesis to validate that Type 2 
Customers are, in fact, significantly more satisfied. 

Overall Satisfaction by Customer Type
Customer Type = 1 Customer Type = 2 Customer Type = 3

Count 31 42 27
Mean 3.3935 4.2052 3.6411
Stdev 0.824680 0.621200 0.670478
Range 3.0800 2.5600 2.7400
Minimum 1.7200 2.4200 2.1900
25th Percentile (Q1) 2.8100 3.8275 3.2400
50th Percentile (Median) 3.5600 4.3400 3.5100
75th Percentile (Q3) 4.0200 4.7250 4.1700
Maximum 4.8000 4.9800 4.9300
95.0% CI Mean 3.091054 to 3.696043 4.011659 to 4.398818 3.375879 to 3.906344
95.0% CI Sigma 0.659012 to 1.102328 0.511126 to 0.792132 0.528013 to 0.918845
Anderson-Darling Normality Test A-Squared = 0.312776; P-Value = 0.5306 A-Squared = 0.826259; P-Value = 0.0302 A-Squared = 0.389291; P-Value = 0.3600
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Tip: Click on Column B, click Window > Split, Window > Freeze Panes.  This freezes 
Column A and allows you to scroll across the Descriptive Statistics for each level of the 
Group Category. This is particularly beneficial when there are a large number of columns. 

7. Click “Recall SigmaXL Dialog” menu or press F3 to recall last dialog.  Change the format 
selected to Column Format as shown: 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  Descriptive Statistics are given for Customer Satisfaction broken out by Customer 
Type in Column Format: 
 
 
 
Tip: This column format is useful to create subsequent graphs on the summary statistics. 
 

Overall Satisfaction by Customer Type Count Mean Stdev Range Minimum 25th Percentile (Q1) 50th Percentile (Median) 75th Percentile (Q3) Maximum 95.0% CI Mean 95.0% CI Sigma
Customer Type = 1 31 3.3935 0.824680 3.0800 1.7200 2.8100 3.5600 4.0200 4.8000 3.091054 to 3.696043 0.659012 to 1.102328
Customer Type = 2 42 4.2052 0.621200 2.5600 2.4200 3.8275 4.3400 4.7250 4.9800 4.011659 to 4.398818 0.511126 to 0.792132
Customer Type = 3 27 3.6411 0.670478 2.7400 2.1900 3.2400 3.5100 4.1700 4.9300 3.375879 to 3.906344 0.528013 to 0.918845
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Part D – Histograms 

Single (Basic) Histogram 

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet). 

2. Click SigmaXL > Graphical Tools > Basic Histogram 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

4. Select Overall Satisfaction, click Numeric Data Variable (Y) >> as shown: 
 
 
 
 
 
 
 
 
 
 
 

5. Click Next. 
 

6. Check Normal Curve.  Set Start Point = 1. Change the Bin Width to 0.5, and the number of 
bins to 8.  Click Update Chart to view the histogram.  (If the survey satisfaction data was 
pure integer format we would have checked the Integer Data option). 
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7. Click Finish.  A histogram of Overall Customer Satisfaction is produced. 
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8. Note that bin one is 1 to  < 1.5,  bin 2 is 1.5 to < 2, etc. 
 
Tip: Any graph produced by SigmaXL can be copied/pasted into Word. It can also be 
enlarged by clicking on the graph and dragging the corner.  The number of decimal places 
displayed can be modified by clicking on the axis label and selecting the Number tab to 
adjust.  The text label alignment can also be modified by selecting the Alignment tab. 

Multiple Histograms 

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet). 

2. Click SigmaXL > Graphical Tools > Histograms & Descriptive Statistics. 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

4. Select Overall Satisfaction, click Numeric Data Variables (Y) >>, select Customer Type, 
click Group Category (X1) >> as shown: 
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5. Click OK. Multiple Histograms and Descriptive Statistics of Customer Satisfaction By 
Customer Type are produced: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Clearly Customer Type 2 shows a higher level of overall satisfaction, with the data skewed 
left.  Note that Customer Type 1 and 3 have data that is normally distributed, but this is not 
desirable when the response is a satisfaction score! 
 

0

2

4

6

8

10

12

1.
72

1.
99

2.
26

2.
54

2.
81

3.
08

3.
35

3.
62

3.
90

4.
17

4.
44

4.
71

4.
98

Overall Satisfaction - Customer Type: 1

0

2

4

6

8

10

12

1.
72

1.
99

2.
26

2.
54

2.
81

3.
08

3.
35

3.
62

3.
90

4.
17

4.
44

4.
71

4.
98

Overall Satisfaction - Customer Type: 2

0

2

4

6

8

10

12

1.
72

1.
99

2.
26

2.
54

2.
81

3.
08

3.
35

3.
62

3.
90

4.
17

4.
44

4.
71

4.
98

Overall Satisfaction - Customer Type: 3

Overall Satisfaction - Customer Type: 1

Count = 31
Mean = 3.3935
Stdev = 0.824680
Range = 3.1

Minimum = 1.7200
25th Percentile (Q1) = 2.8100
50th Percentile (Median) = 3.5600
75th Percentile (Q3) = 4.0200
Maximum = 4.8

95% CI Mean = 3.09 to 3.7
95% CI Sigma = 0.659012 to 1.102328

Anderson-Darling Normality Test:
A-Squared = 0.312776; P-value = 0.5306

Overall Satisfaction - Customer Type: 2

Count = 42
Mean = 4.2052
Stdev = 0.621200
Range = 2.6

Minimum = 2.4200
25th Percentile (Q1) = 3.8275
50th Percentile (Median) = 4.3400
75th Percentile (Q3) = 4.7250
Maximum = 4.98

95% CI Mean = 4.01 to 4.4
95% CI Sigma = 0.511126 to 0.792132

Anderson-Darling Normality Test:
A-Squared = 0.826259; P-value = 0.0302

Overall Satisfaction - Customer Type: 3

Count = 27
Mean = 3.6411
Stdev = 0.670478
Range = 2.7

Minimum = 2.1900
25th Percentile (Q1) = 3.2400
50th Percentile (Median) = 3.5100
75th Percentile (Q3) = 4.1700
Maximum = 4.93

95% CI Mean = 3.38 to 3.9
95% CI Sigma = 0.528013 to 0.918845

Anderson-Darling Normality Test:
A-Squared = 0.389291; P-value = 0.3600

6. Note that bin one is 1.72 to  < 1.99,  bin 2 is 1.99 to < 2.26, etc.  The number of decimals 
displayed can be changed by double-clicking on the X axis, click Number tab, and adjust 
decimal places.  
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Part E – Boxplots 

Boxplots 

1. Click Sheet 1 Tab of  Customer Data.xls (or press F4 to activate last worksheet).   

2. Click SigmaXL > Graphical Tools > Boxplots 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

4. Select Overall Satisfaction, click Numeric Data Variable (Y) >>, select Customer Type, click 
Group Category (X1) >>, check Show Mean: 
 
 
 
 
 
 
 
 
 

5. Click OK.  A boxplot of Customer Satisfaction By Customer Type is produced: 
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6. The solid center line is the median. The dashed red line shows the sample mean.  The top of 
the box is the 75th percentile (Q3).  The bottom of the box is the 25th percentile (Q1). The 
height of the box is called the Inter-Quartile Range (IQR) and is a robust measure of spread 
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or sample variability. The data point highlighted for Customer Type 2 is a potential outlier. 
Note that extreme outliers are highlighted with a solid dot. 

7. Now we will modify the Y axis scale, showing 1 as minimum and 5 as maximum (given that 
the response data comes from a survey with 1-5 scale).  To do this double click on the Y axis, 
select Scale, modify the minimum value and maximum value.  Change category (X) axis 
crosses at: to 1 as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  The Boxplot axis is modified as shown below: 
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9. Click “Recall SigmaXL Dialog” menu or press F3 to recall last dialog. 

10. Select Overall Satisfaction as the Numeric Data Variable (Y) ; select Customer Type as 
Group Category (X1)  and Size of Customer as Group Category (X2); check Show Mean: 
  
 
 
 
 
 
 
 
 
 

11. Click OK.  Boxplots of Customer Satisfaction By Customer Type and Size are produced: 
 
 
 
 
 
 
 
 
 
 

12. In order to adjust the Y-axis scale for both charts click SigmaXL Chart Tools > Set Chart Y-
Axis Max/Min. 
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13. Click OK. The Y-axis scale maximum and minimum are now modified for both charts. 
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Part F – Normal Probability Plots 

Normal Probability Plots 

1. Create 100 random normal values as follows: Click SigmaXL > Data Manipulation > Normal 
Random Data.  Specify 1 column, 100 rows, mean of 100 and standard deviation of 25 as 
shown below: 
 
 
 
 
 
 
 
 
 
 

2. Click OK. Change Column heading to “Normal Data” 

3.  Create a Histogram & Descriptive Statistics for this data.  Your data will be slightly different 
due to the random number generation: 
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Count = 100
Mean = 98.796
Stdev = 24.990
Range = 134.7

Minimum = 26.938
25th Percentile (Q1) = 78.947
50th Percentile (Median) = 97.125
75th Percentile (Q3) = 114.74
Maximum = 161.63

95% CI Mean = 93.84 to 103.8
95% CI Sigma = 21.94 to 29.03

Anderson-Darling Normality Test:
A-Squared = 0.24378; P-value = 0.7587

If the p-value of the Anderson-Darling Normality test is greater than or equal to .05, the data 
is considered to be normal (interpretation of p-values will be discussed further in Analyze). 
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4. Create a normal probability plot of this data: Click Normal Random Data (1) Sheet, Click 
SigmaXL > Graphical Tools > Normal Probability Plots. 

5. Ensure that Normal Data column is selected, click Next. 
 

6. Select Normal Data as Numeric Data Variable (Y). Check Add Titles. Enter “Example 
Normal Prob Plot”.  
 

7.  Click OK. Normal Probability Plot of simulated random data is produced: 
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The data points follow the straight line fairly well, indicating that the data is normally 
distributed.  Note that the data will not likely fall in a perfectly straight line.  The eminent 
statistician George Box uses a “Fat Pencil” test where the data, if covered by a fat pencil, can be 
considered normal!  We can also see that the data is normal since the points fall within the 
normal probability plot 95% confidence intervals (confidence intervals will be discussed further 
in Analyze). 

8. Click Sheet 1 Tab of  Customer Data.xls 

9. Click SigmaXL > Graphical Tools > Normal Probability Plots 

10. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 
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11. Select Overall Satisfaction as Numeric Data Variable (Y).  Click OK. Normal Probability 
Plot of Customer Satisfaction data is produced: 
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Is this data normally distributed?  See earlier histogram and descriptive statistics of Customer 
Satisfaction data. 
 

12. Now we would like to stratify the customer satisfaction score by customer type and look at 
the normal probability plots.   

13. Click Sheet 1 of Customer Data.xls. Click SigmaXL > Graphical Tools > Normal 
Probability Plots. Ensure that Entire Table is selected, click Next.  (Alternatively press F3 or 
click Recall SigmaXL Dialog to recall last dialog). 

14. Select Overall Satisfaction as Data Variable (Y), Customer Type as Group Category (X).  
Click OK. Normal Probability Plots of Overall Satisfaction by Customer Type are produced: 
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Reviewing these normal probability plots, along with the previously created histograms and 
descriptive statistics, we see that the satisfaction data for customer type 2 is not normal, and skewed 
left, which is desirable for satisfaction data!  Note that although the customer type 2 data falls within 
the 95% confidence intervals, the Anderson Darling test from descriptive statistics shows p < .05 
indicating non-normal data. Smaller sample sizes tend to result in wider confidence intervals, but we 
still see that the curvature for customer type 2 is quite strong.  
 
Tip: Use the Normal Probability Plot (NPP) to distinguish reasons for non-normality. If the data 
fails the Anderson Darling (AD) test (with p < 0.05) and forms a curve on the NPP, it is inherently 
non-normal or skewed.  Calculations such as Sigma Level, Pp, Cp, Ppk, Cpk assume normality and 
will therefore be affected.  Consider transforming the data using LN(Y) or SQRT(Y) or using the 
Box-Cox Transformation tool (SigmaXL > Data Manipulation > Box-Cox Transformation) to make 
the data normal.  Of course, whatever transformation you apply to your data, you must also apply to 
your specification limits.  
 
If the data fails the AD normality test, but the bulk of the data forms a straight line and there are 
some outliers, the outliers are driving the non-normality. Do not attempt to transform this data!  
Determine the root cause for the outliers and take corrective action on those root causes. 
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Part G – Run Charts 

Run charts, also known as trend charts and time series plots, add the dimension of time to the 
graphical tools. They allow us to see trends and outliers in the data.  Run Charts are a precursor to 
control charts, which add calculated control limits.  Note that Run Charts should be used only on 
unsorted data, in its original chronological sequence. 

Run Charts 

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet). Click 
SigmaXL > Graphical Tools > Run Chart. 

2. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

3. Select Overall Satisfaction, click Numeric Data Variable (Y) >>.  Select “Show Mean”. 
Uncheck Nonparametric Runs Test (this will be discussed later in Part M of Analyze Phase). 
 
 
 
 
 
 
 
 
 

4. Click OK.  A Run Chart of Overall Satisfaction with Mean center line is produced. 
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5. Double click on the Y axis to activate the Format Axis dialog.  Select the Scale tab, change 
Minimum to 1, Maximum to 5., Category X Axis Crosses at 1: 
 
 
 
 
 
 
 
 
 
 
 
 

6. Click OK. 

7. Are there any obvious trends?  Some possible cycling, but nothing clearly stands out.  It may 
be interesting to look more closely at a specific data point.  Any data point value can be 
identified by simply moving the cursor over it:  
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8. A label can be added to a data point by two single-clicks (not a double-click) on the data 
point, followed by a right mouse click, and select Format Data Point.  Select Data Labels tab, 
check value.   
 
 
 
 
 
 
 
 
 
 
 
 

9. Click OK. Resulting Run Chart with label attached to data point: 
 
 
 
 
 
 
 
 
 

1.72

1

1.5

2

2.5

3

3.5

4

4.5

5

1 2 3 4 5 6 7 8 91011121314151617 1819202122232425 2627282930313233 343536373839404142 4344454647484950 5152535455565758 596061626364656667 6869707172737475 7677787980818283 848586878889909192 9394959697989910
0

Ru
n

ha
rt 

-
ve

ra
ll

at
is

fa
ct

io
n

 C
 O

 S

10. This label can be changed to a text comment. Single-click three times on the label and type in 
a comment as shown: 
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Part H – Process Capability 

Process Capability 

1. Open the file Delivery Times.xls.  This contains continuous data of hotel breakfast delivery 
times.  Deviation Time is the deviation around targeted delivery time in minutes.  The 
Critical Customer Requirements (CCR’s) are as follows: USL = 10 minutes late, LSL = -10 
minutes (early). 

2. Let’s begin with a view of the data using Histograms and Descriptive Statistics. Click 
SigmaXL >  Graphical Tools > Histograms & Descriptive Statistics. 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

4. Select Delivery Time Deviation as the Numeric Data Variable (Y).  Click OK. 
 
 
 
 
 
 
 
 
 
 

SigmaXLChartSheet

Delivery Time Deviation

Count = 725
Mean = 6.0036
Stdev = 7.1616
Range = 37.3

Minimum = -11.900
25th Percentile (Q1) = 1.2991
50th Percentile (Median) = 6.2998
75th Percentile (Q3) = 10.666
Maximum = 25.4493

95% CI Mean = 5.48 to 6.5
95% CI Sigma = 6.810972 to 7.550533

Anderson-Darling Normality Test:
A-Squared = 0.708616; P-value = 0.0641
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Note that the data has an average of 6, so on average the breakfast delivery is 6 minutes late.  
Also note the wide variation in delivery times (Stdev = 7.2 minutes).  With the AD p-value > 
.05, this data can be assumed to have a normal distribution. 

5. Click Sheet 1 Tab. Click SigmaXL > Graphical Tools > Histograms & Process Capability. 

6. Select Delivery Time Deviation as the Numeric Data Variable (Y). Enter USL = 10, Target = 
0, LSL = -10, check Normal Curve as shown below: 
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7. Click OK.  Resulting Histogram & Process Capability report is shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
With the Process Performance indices Pp and Ppk < 1, this process is clearly in need of 
improvement.  Note that the difference between Pp and Ppk is due to the off-center process 
mean.  (Cp and Cpk indices are optionally provided when creating Control Charts – these 
will be demonstrated later in the Control Phase).  
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Process Capability for Non-Normal Data  
(Box-Cox Transformation)  
 
An important assumption for Process Capability analysis is that the data be normally distributed. The 
Box-Cox Transformation tool is used to convert non-normal data to normal by applying a power 
transformation.  Box-Cox Power Transformation applies automatic power transformations to data, 
Y^lambda, where lambda varies from -5 to +5.  You may select rounded or optimal lambda for 
storage of the transformed data. Rounded is typically preferred since it will result in a more 
“intuitive” transformation such as Ln(Y) (lambda=0) or SQRT(Y) (lambda=0.5). 
 
The Anderson-Darling normality test is applied to the transformed data so that you can immediately 
see whether or not the final transformation results in normal data. Box-Cox is particularly effective 
for skewed data but will not work on bimodal data, nor should it be used on data where the “non-
normality” is due to outliers.  

1. Open the file Non-Normal Cycle Time.xls.  This contains continuous data of process cycle 
times.  The Critical Customer Requirement is: USL = 1000 minutes. 

2. Let’s begin with a view of the data using Histograms and Descriptive Statistics. Click 
SigmaXL >  Graphical Tools > Histograms & Descriptive Statistics. 

3. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

4. Select Cycle Time (Minutes) as the Numeric Data Variable (Y).  Click OK. 
 
 
 
 
 
 
 
 
 
 
 

69 

Clearly this is a process in need of improvement.  To start, we would like to get a baseline 
process capability.  The problem with simply repeating the above Capability analysis is that 
the results will be incorrect due to the non-normality in the data.  The Histogram and AD p-
value < .05 clearly show that this data is not normal. 
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Cycle Time (Minutes)

Count = 30
Mean = 687.40
Stdev = 1186.9
Range = 6073.0

Minimum = 28
25th Percentile (Q1) = 175.25
50th Percentile (Median) = 361.50
75th Percentile (Q3) = 578.50
Maximum = 6101

95% CI Mean = 244.21 to 1130.6
95% CI Sigma = 945.2441 to 1595.549

Anderson-Darling Normality Test:
A-Squared = 5.286481; P-value = 0.0000
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5. We will confirm the non-normality by using a Normal Probability Plot.  Click Sheet 1 Tab 
(or F4). Click SigmaXL > Graphical Tools > Normal Probability Plots. 

6. Ensure that the entire data table is selected. If not, check “Use Entire Data Table”. Click 
Next. 

7. Select Cycle Time (Minutes) as the Numeric Data Variable (Y).  Click OK. A Normal 
Probability Plot of Cycle Time data is produced: 
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8.  The curvature in this normal probability plot confirms that this data is not normal.  (Note 
that the X axis scale minimum was manually set to 0). 

9. For now, let us ignore the non-normality issue and proceed with the Process Capability study.  
Click Sheet 1 Tab. Click SigmaXL > Graphical Tools > Histograms & Process Capability. 

10. Select Cycle Time (Minutes) as the Numeric Data Variable (Y). Enter USL = 1000, Delete 
previous Target and LSL settings. 
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11. Click OK. The resulting Process Capability Report is shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notice the discrepancy between the Expected Overall (Theoretical) Performance and Actual 
(Empirical) Performance.  This is largely due to the non-normality in the data; the expected 
performance assumes that the data is normal.  Since this assumption is not true, why not just 
use the empirical performance and disregard the theoretical?  This would not work here 
because the sample size, n = 30 is too small to estimate performance using pass/fail (discrete) 
criteria. 
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12. We will now attempt to transform the data using the Box-Cox Power Transformation tool. 
Click Sheet 1 Tab (or F4).  Click SigmaXL > Data Manipulation > Box-Cox Transformation. 
Ensure that the entire data table is selected. If not, check “Use Entire Data Table”. Click 
Next.  

13. Select Cycle Time (Minutes) as the Numeric Data Variable (Y).  
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Tip: The selected variable must contain all positive values. If this is not the case, add a shift 
factor to all of the data equal to: -(minimum value) + 1.  Keep in mind that further analysis 
will require compensation for this shift factor. 
  
Tip:  Note that while this tool is often successful to transform the data to normality, there 
may not be a suitable transformation to make the data normal. The output report indicates the 
Anderson-Darling p-value for the transformed data. You may wish to check “Do not store if 
transformed data is not normal”.  Another option is “Do not store transformed data if Lambda 
= 1 falls within 95%CI”. This latter option prevents you from using transformations that do 
not result in a statistically significant improvement towards normality. 

14. Click OK.  The resulting report is shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

15. The fact that Lambda=1 falls outside of the 95% confidence interval tells us that the 
transformation is statistically significant.  The Anderson-Darling p-value of 0.5063 indicates 
that we cannot reject the null hypothesis that the transformed data is normal, so the Ln 
transformation has successfully converted the data to normality. 
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16. Before we run the Process Capability report on the transformed data, we need to calculate the 
transformed specification limit.  In this case the final lambda was rounded from -.04 to 0, 
which denotes a natural log transformation.  So the proper entry for our specification limit 
will be Ln(1000) = 6.90776. This can be calculated in an Excel cell using the formula 
“=LN(1000)”. 

17. Select cells G1:G31. Click SigmaXL > Graphical Tools > Histograms & Process Capability.  
Select Transformed Data (Ln(Y)) as the Numeric Data Variable (Y). Enter USL = 6.90776. 
 
 
 
 
 
 
 
 
 
 
Tip: If the Final Lambda is negative, be sure to reference the original USL as transformed 
LSL, and original LSL as transformed USL. 

18. Click OK.  The resulting Process Capability report is shown: 
 
 
 
 
 
 
 
 
 
 
 
 
SigmaXLChartSheet
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Stdev (Overall) = 1.16
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Capability Indices using Overall Standard Deviation
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Expected Overall Performance
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19. Note that the Expected Overall Performance is closer to the Actual (Empirical) Performance. 
We can now use the 17.5% defective rate as our baseline level. 
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20. Entering the transformed Mean, Standard Deviation, and Specification Limits into the Sigma 
Level Calculator (SigmaXL > Templates and Calculators > Process Sigma – Continuous), 
gives us a Sigma Level of 2.43. 
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Part A – Stratification with Pareto 

SigmaXL’s Pareto tool allows you to create Basic (Single) or Advanced (Multiple) Pareto Charts.  
Advanced Pareto charts are particularly useful in the Analyze Phase because of the ease with which 
you can slice and dice (or stratify) your data.  Of course, Pareto charts are not limited to the Analyze 
Phase – they can also be used to aid project selection and to prioritize in the Measure Phase. 

Consider the following guidelines to help ensure that your Pareto analysis is successful: 

• Your Pareto analysis will only be as good as the quality of the data collected. Ensure that you 
have the right data and that the data is correct. Use other graphs such as run charts to apply a 
sanity check to your data.  

• Check process stability using appropriate control charts. If the process is not in control, your 
prioritization of defects and root causes could be invalid.  

• Avoid collecting data over too short a time period. Your data may not be representative of 
the process as a whole.  

• Conversely, data gathered over too long a time period may include process changes that 
could lead to incorrect conclusions. SigmaXL provides a date subsetting feature that allows 
you to easily explore different time periods.  

• If your initial Pareto analysis does not yield useful results, explore other categories that may 
be important. SigmaXL’s Advanced Charts makes it easy for you to 'slice and dice' your data 
with different X categories.  

• Consider Pareto charting measures such as cost and severity, in addition to defect counts. 
SigmaXL enables you to chart multiple Y responses. 
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Basic (Single) Pareto Charts 

1. Open the file Customer Data.xls.  Click SigmaXL > Graphical Tools > Basic Pareto Chart. 

2. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

3. Select Major-Complaint as the Pareto Category (X).   
 
 
 
 
 
 
 
 
 
 
Tip: SigmaXL will automatically count the number of unique items in the Pareto Category. 
If we had a separate column with a count (or cost), this count column would be selected as 
the Optional Numeric Count (Y). 

4. Click Next. Set Basic Chart Options as follows: 
Tab “Other” Bar/Cum Sum:   
 Cum Sum Line – On Top of First Bar 
 
 
 
 
 
 
 
Tab Chart Options 
 Category (X) Font – Slanted 
 Data Labels – Check Bars, Cum Sum  
Check Save Defaults 
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Tip: After you have saved your defaults, you can bypass the above options, by clicking 
“Finish” instead of “Next” at the original Basic Pareto Chart dialog box.  The saved defaults 
will automatically be applied. 

5. Click Finish. The Pareto Chart is produced: 
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Advanced (Multiple) Pareto Charts 

1. Click Sheet1 Tab of Customer Data.xls (or press F4 to activate last worksheet). 

2. Click SigmaXL > Graphical Tools > Advanced Pareto Options. 
Note that the Sample Charts have nothing to do with the data set being evaluated. They are 
used to dynamically illustrate how your options affect the charts to be produced. 

3. Set Order of Bars to “Same Order” on the “Other Bar”/Cum Sum options tab. 
This is typically used for comparative purposes.  The Descending Order option makes each 
Chart a true Pareto Chart, but is less useful for comparison. 

 

 
 

 

 

4. Click Chart Options tab. Set according to choice – in this case we have selected Data Labels 
for the Bars but not for the Cum Sum line. 
 

 

 

 

 

5. Ensure that Save Defaults is checked.  Note that these options will be saved and applied to all 
Advanced Pareto Charts.  Click Finish. 
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6. SigmaXL automatically takes you to the next step of Chart Generation (This is equivalent to 
clicking SigmaXL > Graphical Tools > Advanced Pareto Charts).  If necessary, check “Use 
Entire Data Table” 

7. Click Next.   

8. Select Major Complaint as X1, Customer Type as X2. 
 
 
 
 
 
 
 
 
 
 
 

9. Click OK.  A Pareto Chart of Major Customer Complaints is produced for each Customer 
Type. 
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10. Click Sheet 1 Tab, Click SigmaXL > Graphical Tools > Advanced Pareto Charts. 

11. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next.  
(Steps 10 and 11 can be bypassed with the “Recall SigmaXL Dialog” menu or by pressing F3 
to recall last dialog). 

12. Select Major Complaint as X1, Size of Customer as X2, and Product Type as X3. 
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If a Numeric Count (Y) variable is not specified, SigmaXL automatically determines the 
counts from the Pareto Category (X1).  

Normally we would use a text column of discrete Xs, but be aware that numeric columns are 
also allowed.  Be careful here – this could easily generate a very large number of charts.  

The total number of charts generated = (# of levels in X2) * (# of levels in X3) * (# of levels 
in X4) * (# of Y variables). 

13. Click OK.  Multiple Paretos are generated: 
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Part B - EZ-Pivot  

One of the most powerful features in Excel is the Pivot table.  However, this tool is often not used 
due to the non-intuitive nature of the interface.  SigmaXL’s EZ-Pivot tool simplifies the creation of 
Pivot tables using the familiar X and Y dialog box found in the previous Pareto tools. 

Example of Three X’s, No Response Y’s 

1. Open Customer Data.xls, click Sheet 1 (or press F4 to activate last worksheet).  Select 
SigmaXL > click EZ-Pivot 

2. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

3. Select Major Complaint as X1.  Note that if Y is not specified, the Pivot Table Data is based 
on a count of X1, hence the name Count Category. 

4. Select Customer Type as X2; Size of Customer as X3 as shown. 
 
 
 
 
 
 
 
 
 
 
 

5. Click OK.  Resulting Pivot Table of Major Complaint by Customer Type is shown: 
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6. This Pivot table shows the counts for each Major Complaint (X1), broken out by Customer 
Type (X2), for all Sizes of Customers (X3).  (Grand Totals can be added to the Pivot Table 
by using Pivot Table Toolbar > Table Options. Check Grand Totals for Columns, Grand 
Totals for Rows). 

7. To display counts for a specific Customer Size, click the arrow adjacent to Size of Customer 
(All).  Select Large. 
 
 
 
 
 

 

 

8. Click OK.  Resulting Pivot Table is: 
 
 
 
 
 
 

Note that the Major Complaint “Not-Available” is not shown. Pivot table only show rows 
where there is at least a count of one. 

9. The Pivot Chart can be seen by clicking the EZ Pivot Chart (1) tab; reset Size of Customer to 
All as shown below: 
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10. Drag the Size of Customer button adjacent to the left of the Major Complaint button and 
Excel will automatically split the Pivot Chart showing both Large and Small Customers. 
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Example of Three X’s and One Y 

1. Select Sheet 1 Customer Data.xls; click SigmaXL > EZ-Pivot; click Next (alternatively, 
click “Recall SigmaXL Dialog” menu or press F3 to recall last dialog). 

2. Select Customer Type as X1; Size of Customer as X2; Product Type as X3; Overall 
Satisfaction as Y. Note that the Label for X1 changed from Count Category to Group 
Category.  The Pivot Table data will now be based on Y data. 

3. The Response default uses a Sum of Y.  This however can be changed to Average or 
Standard Deviation. Select Average.  Uncheck “Create Pivot Charts” (Since we are looking 
at averages, the stacked bar Pivot Charts would not be very useful, unless they are changed to 
“clustered column” format using Chart > Chart Type). 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click Ok.  The resulting Pivot Table is: 
 
 
 
 
 
 

5. Note that the table now contains Averages of the Customer Satisfaction scores (Y).  Again 
Product Type (X3) can be varied to show Consumer, Manufacturer, or All.  Double clicking 
on “Average of Overall Satisfaction” allows you to switch to Standard Deviation (StdDev). 
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Example of 3 X’s and 3 Y’s 

1. Click “Recall SigmaXL Dialog” menu or press F3 to recall last dialog. 

2. Set X1=Customer Type; X2=Size of Customer; X3=Product Type; Y1=Avg Days Order to 
Delivery; Y2=Loyalty; Y3=Overall Satisfaction. Select Average and One Pivot Table 
(default is separate Pivot Tables for each Y). Uncheck “Create Pivot Charts”. 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click OK.  Resulting Pivot Table: 
 
 
 
 
 
 
 
 
 
 

4. Again, Product Type (X3) can be varied. 
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Part C – Confidence Intervals 

Confidence Intervals 

1. Confidence Intervals can be obtained in several ways with SigmaXL: Descriptive 
Statistics, Histograms & Descriptive Statistics, 1-Sample t-test and Confidence Intervals, 
One-Way ANOVA, and Multi-Vari Charts.  

2. Open Customer Data.xls. Click Sheet 1 Tab (or press F4 to activate last worksheet). 

3. Click SigmaXL > Statistical Tools > Descriptive Statistics 

4. Check  “Use Entire Data Table”, click Next 

5. Select Overall Satisfaction, click Numeric Data Variables (Y) >>. Select Customer Type, 
click Group Category (X1) >>; Confidence level default is 95%: 
 
 
 
 
 
 
 
 
 
 
 

6. Click OK. Descriptive Statistics are given for Customer Satisfaction broken out by 
Customer Type: 
 
 
 
 
 
 

Overall Satisfaction by Customer Type
Customer Type = 1 Customer Type = 2 Customer Type = 3

Count 31 42 27
Mean 3.3935 4.2052 3.6411
Stdev 0.824680 0.621200 0.670478
Range 3.0800 2.5600 2.7400
Minimum 1.7200 2.4200 2.1900
25th Percentile (Q1) 2.8100 3.8275 3.2400
50th Percentile (Median) 3.5600 4.3400 3.5100
75th Percentile (Q3) 4.0200 4.7250 4.1700
Maximum 4.8000 4.9800 4.9300
95.0% CI Mean 3.091054 to 3.696043 4.011659 to 4.398818 3.375879 to 3.906344
95.0% CI Sigma 0.659012 to 1.102328 0.511126 to 0.792132 0.528013 to 0.918845
Anderson-Darling Normality Test A-Squared = 0.312776; P-Value = 0.5306 A-Squared = 0.826259; P-Value = 0.0302 A-Squared = 0.389291; P-Value = 0.3600
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We are given the 95% confidence interval for each sample Mean (95% CI Mean) as well as the 95% 
confidence interval for the Standard Deviation (95% CI Sigma). 
 
These confidence intervals are very important in understanding our data and making decisions from 
the data.  How often are we driven by sample estimates only and fail to consider the confidence 
interval or margin of error? For example, newspapers will often fail to take into account the 
confidence interval when reporting opinion poll results.  (To calculate confidence intervals for 
discrete data, use SigmaXL > Templates & Calculators > 1 Proportion Confidence Interval).  
 
Note that a confidence interval of 95% implies that, on average, the true population parameter 
(Mean, Median, Sigma, or Proportion) will lie within the interval 19 times out of 20. 
 
A confidence interval or margin of error does not take into account measurement error or survey 
bias, so the actual uncertainty may be greater than stated.  This should be addressed with good data 
collection, reliable measurement systems, and good survey design. 
 
To illustrate the confidence intervals graphically, we have generated a Multi-Vari Chart (with 95% 
CI Mean Options) using the Customer Data.xls data. This chart type will be covered later (Part O). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The dots correspond to individual data points.  The tick marks show the 95% upper confidence limit, 
mean, and 95% lower confidence limit. Clearly we can see that Customer Type 2 has a significantly 
higher level of  mean satisfaction; the lower limit does not overlap with the upper limit for Types 1 
and 3. On the other hand we see overlap of the CI’s when comparing types 1 and 3.  Hypothesis 
testing will now be used to compare the mean satisfaction scores more precisely and determine 
statistical significance for the results. 
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Part D – Hypothesis Testing – One Sample t-Test 

Hypothesis Testing – One Sample t-Test 

 
1. Open Customer Data.xls, select Sheet 1 tab (or press F4 to activate last worksheet).  Click 

SigmaXL > Statistical Tools > 1 Sample t-Test & Confidence Intervals. If necessary, check 
Use Entire Data Table, click Next. 

2. Ensure that “Stacked Column Format” is selected.  Select Overall Satisfaction as Numeric 
Data Variable (Y), Customer Type as Optional Group Category (X). 

3. Historically, our average customer satisfaction score has been 3.5. We would like to see if 
this has changed, with the results grouped by customer type.  Null Hypothesis H0: μ=3.5; 
Alternative Hypothesis Ha: μ≠3.5 

4.  Enter 3.5 for the Null Hypothesis H0 value.  Keep Ha as “Not Equal To”. 
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5. Click OK.  Results: 
 
 
 
 
 
 
 
 
 
 
 

6. Note the p-values. Customer Type 2 shows a significant change (increase) in Satisfaction 
Mean (p-value < .05), whereas Customer Types 1 and 3 show no change (p-value ≥ .05).  
Also note the confidence intervals around each mean match the results from Descriptive 
Statistics. 

7. In the Measure Phase we determined that Overall Satisfaction for Customer Type 2 has non-
normal data but this does not imply that the p-value for the 1 Sample t-test is wrong. The 
Central Limit Theorem applies here: the distribution of averages tends to be normal, even if 
the individual observations are not-normal.  With a sample size of 42, the t-test is fairly 
robust against skewed data. 
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Part E – Power and Sample Size 

Power and Sample Size – One Sample t-Test – Customer Data 

Using the One Sample t-Test, we determined that Customer Types 1 and 3 resulted in “Fail to reject  
H0: μ=3.5”.  A failure to reject H0 does not mean that we have proven the null to be true. The 
question that we want to consider here is “What was the power of the test?”  Restated, “What was 
the likelihood that given Ha: μ≠3.5 was true, we would have rejected H0 and accepted Ha?”  To 
answer this, we will use the Power and Sample Size Calculator. 

1. Click SigmaXL > Statistical Tools > Power and Sample Size Calculators > 1 Sample t-Test 
Calculator.  We will only consider the statistics from Customer Type 3 here. We will treat the 
problem as a two sided test with Ha: “Not Equal To” to be consistent with the original test.  

2. Enter 27 in Sample Size (N).  The difference to be detected in this case would be the difference 
between the sample mean and the hypothesized value i.e. 3.6411 – 3.5 = 0.1411.  Enter 0.1411 in 
Difference.  Leave Power value blank, with “Solve For” Power selected (default).  Given any 
two values of Power, Sample size, and Difference, SigmaXL will solve for the remaining 
selected third value.  Enter the sample standard deviation value of 0.6405 in Standard Deviation. 
Keep Alpha and Ha at the default values as shown: 
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3. Click OK. The resulting report is shown: 
 
 
 
 
 
 
 

4. A power value of 0.1968 is very poor. It is the probability of detecting the specified difference.  
Alternatively, the associated Beta risk is 1-0.1968 = 0.8032 which is the probability of failure to 
detect such a difference.  Typically, we would like to see Power > 0.9 or Beta < 0.1.  In order to 
detect a difference this small we would need to increase the sample size. We could also set the 
difference to be detected as a larger value. 

5. First we will determine what sample size would be required in order to obtain a Power value of 
0.9.  Click “Recall SigmaXL Dialog” menu or press F3 to recall last dialog.  Select the “Solve 
For” Sample Size button as shown.  It is not necessary to delete the entered sample size of 27 – it 
will be ignored.  Enter a Power Value of .9: 
 
 
 
 
 
 
 
 
  
 
 
 
 
 

6. Click OK. The resulting report is shown: 
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7. A sample size of 219 would be required to obtain a power value of 0.9.  The actual power is 
rarely the same as the desired power due to the restriction that the sample size must be an 
integer.  The actual power will always be greater than or equal to the desired power. 

8. Now we will determine what the difference would have to be to obtain a Power value of 0.9, 
given the original sample size of 27.  Click “Recall SigmaXL Dialog” menu or press F3 to recall 
last dialog.  Select the “Solve For” Difference button as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 

9. Click OK. The resulting report is shown: 
 
 
 
 
 
 

10. A difference of 0.415 would be required to obtain a Power value of 0.9, given the sample size of 
27. 
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Power and Sample Size – One Sample t-Test – Graphing the 
Relationships between Power, Sample Size, and Difference 

In order to provide a graphical view of the relationship between Power, Sample Size, and Difference, 
SigmaXL provides a tool called Power and Sample Size with Worksheets.  Similar to the 
Calculators, Power and Sample Size with Worksheets allows you to solve for Power (1 – Beta), 
Sample Size, or Difference (specify two, solve for the third).  You must have a worksheet with 
Power, Sample Size, or Difference values.  Other inputs such as Standard Deviation and Alpha can 
be included in the worksheet or manually entered. 

1. Open the file Sample Size and Difference Worksheet.xls, select the Sample Size & Diff 
sheet tab. Click SigmaXL > Statistical Tools > Power & Sample Size with Worksheets > 1 
Sample t-Test.  If necessary, check “Use Entire Data Table”.  Click Next. 

2. Ensure that “Solve For” Power (1 – Beta) is selected.  Select Sample Size (N) and Difference 
columns as shown.  Enter the Standard Deviation value of 1.  Enter .05 as the Significance 
Level value: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click OK. The output report is shown below: 
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4. To create a graph showing the relationship between Power, Sample Size and Difference, 
click SigmaXL > Statistical Tools > Power & Sample Size Chart.  Check “Use Entire Data 
Table”.  Click Next. 

5. Select Power (1 – Beta) for the Y Axis, Sample Size (N) for the X axis, and Difference as the 
Group Category variable.  Click Add Title.  Enter “Power & Sample Size: 1 Sample t-Test”: 
 
 
 
 
 
 
 

6. Click OK.  The resulting Power & Sample Size Chart is displayed: 
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Part F – One Sample Nonparametric Tests 

Introduction to Nonparametric Tests 

Nonparametric tests make fewer assumptions about the distribution of the data compared to 
parametric tests like the t-Test.  Nonparametric tests do not rely on the estimation of parameters such 
as the mean or the standard deviation. They are sometimes called distribution-free tests. 

Nonparametric tests use Medians and Ranks, thus they are robust to outliers in the data.  If, however, 
the data are normal and free of outliers, nonparametric tests are less powerful than normal based 
tests to detect a real difference when one exists. 

Nonparametric tests should be used when the data are non-normal, data cannot be readily 
transformed to normality, and sample size is small (n < 30).  If the sample sizes are large, the Central 
Limit Theorem says that parametric tests are robust to non-normality. 

One Sample Sign Test 

The sign test is the simplest of the nonparametric tests, and is similar to testing if a two-sided coin is 
fair.  Count the number of positive values (larger than hypothesized median), the number of negative 
values (smaller than the hypothesized median), and test whether there are significantly more 
positives (or negatives) than expected.  The One Sample Sign Test is a nonparametric equivalent to 
the parametric One Sample t-Test. 

Historically, our Median customer satisfaction score has been 3.5. We would like to see if this has 
changed, with the results grouped by customer type  (H0: Median=3.5, Ha: Median≠3.5, α = 0.05). 

 
1. Open Customer Data.xls, select Sheet 1 tab.  Click SigmaXL > Statistical Tools > 

Nonparametric Tests > 1 Sample Sign.  If necessary, check “Use Entire Data Table”, click Next. 

2. Ensure that “Stacked Column Format” is selected.  Select Overall Satisfaction as Numeric Data 
Variable (Y), Customer Type as Optional Group Category (X). 

3. Enter 3.5 for the Null Hypothesis H0 value.  Set Ha as “Not Equal To”. 
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4. Click OK.  Results: 
 
 
 
 
 
 
 
 
 

5. Note the p-values. Customer Type 2 shows a significant change (increase) in Satisfaction Median 
(p-value < .05), whereas Customer Types 1 and 3 show no change (p-value ≥ .05).  While the p-
values are not the same as those given by the 1 sample t-Test, the conclusions do match. we 
discussed that requires a nonparametric test. 

One Sample Wilcoxon Signed Rank Test 

The Wilcoxon Signed Rank test is a more powerful nonparametric test than the Sign Test, but it adds 
an assumption that the distribution of values is symmetric around the median.  An example of a 
symmetric distribution is the uniform distribution.  Symmetry can be observed with a histogram, or 
by checking to see if the median and mean are approximately equal. 

The One Sample Wilcoxon Test is a nonparametric equivalent to the parametric One Sample t-Test. 
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Historically, our Median customer satisfaction score has been 3.5. We would like to see if this has 
changed, with the results grouped by customer type  (H0: Median=3.5, Ha: Median≠3.5, α = 0.05). 

 
1. Open Customer Data.xls, select Sheet 1 tab (or press F4 to activate last worksheet).  Click 

SigmaXL > Statistical Tools > Nonparametric Tests > 1 Sample Wilcoxon.  If necessary, check 
“Use Entire Data Table”, click Next. 

2. Ensure that “Stacked Column Format” is selected.  Select Overall Satisfaction as Numeric Data 
Variable (Y), Customer Type as Optional Group Category (X). 

3. Enter 3.5 for the Null Hypothesis H0 value.  Keep Ha as “Not Equal To”. 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  Results: 
 
 
 
 
 
 
 
 
 
Note the p-values. Customer Type 2 shows a significant change (increase) in Satisfaction Median 
(p-value < .05), whereas Customer Types 1 and 3 show no change (p-value ≥ .05).  Although the 
p-values are not identical to the sign test and t-Test, the conclusions match. (Note, in the case of 
Customer Type 2, the Sign Test is preferred since the data is not symmetrical but skewed). 
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Part G – Two Sample t-Test 

Two Sample t-Test 

1. Open Customer Data.xls, click Sheet 1 tab (or press F4 to activate last worksheet).  We will 
look at comparing means of Customer Satisfaction by Customer Type ( 2 vs. 3), using the 
Two Sample t-test.  H0: μ2=μ3, Ha: μ2≠μ3 

2. Click SigmaXL > Statistical Tools > 2 Sample t-test. If necessary, check Use Entire Data 
Table, click Next. 

3. With stacked column format checked, select Overall Satisfaction as Numeric Data Variable 
Y; Customer Type as Group Category X; H0: Mean Diff = 0; Ha: “Not Equal To”; 
Confidence Level: 95%; ensure that “Assume Equal Variances” is checked: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  Select Customer Type 2 and 3. 
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5. Click OK.  Resulting output: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Given the p-value of .0007 we reject H0 and conclude that Mean Customer Satisfaction is 
significantly different between Customer type 2 and 3.  This confirms previous findings. 
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Paired t-Test 

1. Open the file Dietcola.xls.  These are the results of a Before and After taste test on sweetness 
for diet cola.  Ten tasters were used and one month elapsed with the cola in warm storage 
between the before and after results.  Do a one sample t-test on the column of differences. 

2. Click SigmaXL > Statistical Tools > 1-Sample t-test & Confidence Intervals.  Ensure that 
entire data table is selected. If not, check “Use Entire Data Table”. Click Next, Select 
Difference as Y, set H0: Mean μ=0, Ha: Less Than (this is a one-sided or one-tail test – 
sweetness cannot increase): 
 
 
 
 
 
 
 
 
 
 
 

3. Click OK.  Result: 
 
 
 
 
 
 
 
 
 
 
 
Given the p-value of .012, we reject H0 and conclude that the sweetness has in fact 
decreased. 
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4. Now redo the analysis using the paired t-test: Click Sheet 1 Tab; Click SigmaXL > Statistical 
Tools > Paired t-Test; Click Next; Select After as Data Variable 1, Before as Data Variable 2, 
H0: Mean Diff = 0, Ha: “Less Than” 
 
 
 
 
 
 
 
 
 
 
 
 

5. Click OK. Results are identical to One sample analysis of difference column: 
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Unpaired 2 Sample t-Test vs. Paired t-Test 

1. Open the Dietcola.xls file, click the Sheet 1 tab (or press F4 to activate last worksheet). 

2. Click SigmaXL > Statistical Tools > 2 Sample t-test. Ensure that entire data table is selected. 
If not, check “Use Entire Data Table”. Click Next. 

3. Check Unstacked Column Format.  Select After, Before and click Numeric Data Variables 
(Y).  H0: Mean Diff = 0, Ha: “Less Than”, check “Assume Equal Variances”: 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  Results: 
  
 
 
 
 
 
 
 
 
 
 
 
 
Now the p-value is .07, indicating a fail to reject H0.  What changed?  Hint: Compare the SE 
Mean of the Paired t-test to the Std Error Difference of the unpaired two-sample t-test.  
Where does the additional variability come from in the two-sample t-test?  The paired t-test 
is the appropriate test to use here. 
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Power & Sample Size for 2 Sample T-Test 

To determine Power & Sample Size for a 2 Sample t-Test, you can use the Power & Sample Size 
Calculator or Power & Sample Size with Worksheet.   

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > 2 Sample t-Test 
Calculator  

2. Select “Solve For” Power (1 – Beta).  Enter Sample Size and  Difference as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that we are calculating the power or likelihood of detection given that Mean1 – Mean2 
= 1, with sample size for each group = 30, standard deviation = 1, significance level = .05, 
and Ha: Not Equal To (two-sided test). 

3. Click OK. The resulting report is displayed: 
 
 
 
 
 
 
 
A power value of 0.97 is good, hence we have the basis for the “minimum sample size n=30” 
rule of thumb used for continuous data. 
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4. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > 
Power & Sample Size with Worksheet > 2 Sample t-Test. 

5. A graph showing the relationship between Power, Sample Size and Difference can then be 
created using SigmaXL > Statistical Tools > Power & Sample Size Chart. See Part E for an 
example using the 1 Sample t-Test. 
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Part H – Two Sample Comparison Test 

We will now do a full comparison test of Customer Satisfaction for Customer Type 1 and 2.  This 
test checks each sample for normality, equal variance (F-test and Levene’s), 2 sample t-test 
(assuming equal and unequal variance), and Mann Whitney test for equal Medians.  Depending on 
the normality, variance, and sample size results, the appropriate p-values are highlighted in yellow. 

Two Sample Comparison Test 

1. Open Customer Data.xls, click on Sheet 1 Tab. 

2. Click SigmaXL > Statistical Tools > 2 Sample Comparison Tests. Click Next. Check Stacked 
Column Format.  Select Overall Satisfaction as Y, and Customer Type as X. 
 
 
 
 
 
 
 
 
 
 
 

3. Click OK.  Select Customer Type 1 and 2. 
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4. Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Test 1: Anderson Darling 
H0: Data is Normal 
Ha: Data is Not Normal 

Test 2: Equal Variances 
H0: σ1

2 = σ2
2 

Ha: σ1
2 ≠ σ2

2

Test 3: Equal Means 
H0: μ1 = μ2 
Ha: μ1 ≠ μ2

Test 4: Equal Medians 
H0: Median1 = Median2 
Ha: Median1 ≠ Median2

 
Customer Type 2 has non-normal data.  This makes Levene’s test the appropriate test for unequal 
variance.  Levene’s test indicates that Customer type 2 has a significantly lower variance, or 
standard deviation. The lower standard deviation translates to a consistent level of satisfaction.   

Since Levene’s test indicates unequal variance, the appropriate t-test assumes unequal variance. 
The t-test indicates that Customer Type 2 has a significantly higher mean satisfaction. 

Clearly the next step would be to determine a root cause or best practices to reduce the 
variability in overall satisfaction and increase the mean for all customer types. 
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Part I – Two Sample Nonparametric Test:  
Mann-Whitney 

Two Sample Mann-Whitney Rank Test 

We will look at comparing medians of Customer Satisfaction by Customer Type, using the Two 
Sample Mann-Whitney Rank test.(H0: Median2 = Median3, Ha: Median2 ≠ Median3).  The Two 
Sample Mann-Whitney Test is the nonparametric equivalent to the parametric Two Sample t-
Test.: 

1. Open Customer Data.xls, click Sheet 1 tab (or press F4 to activate last worksheet). 

2. Click SigmaXL > Statistical Tools > Nonparametric Tests > 2 Sample Mann-Whitney.  If 
necessary, check Use Entire Data Table, click Next. 

3. With stacked column format checked, select Overall Satisfaction as Numeric Data Variable 
Y; Customer Type as Group Category X;  and Ha: “Not Equal To”: 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  Select Customer Type 2 and 3. 
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5. Click OK.  Resulting output: 
 
 
 
 
 
 
 
 
 
Given the p-value of .0008 we reject H0 and conclude that Median Customer Satisfaction is 
significantly different between Customer types 2 and 3.  This confirms previous findings and 
matches the results of the 2 Sample t-Test. 
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Part J – One-Way ANOVA & Means Matrix 

One-Way ANOVA & Means Matrix 

1. One-Way ANOVA and Means Matrix allows you to quickly do multiple pairwise 
comparisons.  The One-Way ANOVA tests H0: μ1 = μ2 = μ3; Ha: at least one pairwise set of 
means are not equal. 

2. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet). 

3. Click SigmaXL > Statistical Tools > One-Way ANOVA & Means Matrix. Ensure that the 
entire data table is selected. If not, check “Use Entire Data Table”.  

4. Click Next. Ensure that “Stacked Column Format” is checked.  Select Overall Satisfaction as 
Y, and Customer Type as X. 
 
 
 
 
 
 
 
 
 
 

5. Click OK.  The results are shown below: 
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6. The ANOVA p-value of 0.0000 tells us that at least one pairwise set of means are not equal. 
From the means matrix, we conclude that Mean Overall Satisfaction is significantly different 
between Customer Type 2 and 3, as well as 1 and 2. 
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7. A graphical view of the Overall Satisfaction Mean and 95% Confidence Intervals are given 
to complement the Means Matrix.  The fact that the CI’s for Customer Type 2 do not overlap 
those of Type 1 or 3, clearly shows that Customer Type 2 has a significantly higher mean 
satisfaction score.  The overlap of CI’s for Type 1 and 3 shows that the mean satisfaction 
scores for 1 and 3 are not significantly different. 

8. The R-Square (R-Sq) value of 20.95% indicates that Customer type “explains” 
approximately 21% of the variation in Overall Satisfaction.  We need to “drill down” to 
understand the root causes and best practices associated with Customer Type 2. 

9. Note that the p-value for 2-3 is slightly different than the previous two sample test result 
because the variances from all 3 customer types are “pooled” here.  This also results in 
slightly different confidence intervals. One-Way ANOVA & Means Matrix assume equal 
variance, but analysis above in Part H indicates that this assumption is not true, so this 
analysis should be treated with caution. An alternative nonparametric test is the Kruskal-
Wallis test for Medians (SigmaXL > Statistical Tools > Nonparametric Tests > Kruskal-
Wallis Median Test) or Mood’s Median (SigmaXL > Statistical Tools > Nonparametric Tests 
> Mood’s Median Test).  These are discussed in Part L. 
 
Note also that the means matrix p-values could easily trigger type I errors when the number 
of X levels gets large.  You should only consider the results of the Means Matrix if the 
ANOVA p-value is < .05. 
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Power & Sample Size for One-Way ANOVA 

To determine Power & Sample Size for a One-Way ANOVA, you can use the Power & Sample 
Size Calculator or Power & Sample Size with Worksheet.   

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > One-Way ANOVA 
Calculator.  

2. Select “Solve For” Power (1 – Beta).  Enter Sample Size and  Maximum Difference as 
shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that we are calculating the power or likelihood of detection given that the maximum 
difference between group means = 1, with sample size for each group = 30, 3 groups, 
standard deviation = 1, significance level = .05, and Ha: Not Equal To (two sided test). 

3. Click OK. The resulting report is displayed: 
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A power value of 0.94 is acceptable.  Note that this value is less than the power value of 0.97 
obtained with the two-sample t-Test.   

4. Press F3  or click “Recall SigmaXL Dialog” to recall last dialog.  Change the number of 
groups to 4. Note that the power value is 0.907.  If the number of groups (levels) increase, 
you will have to increase the sample size in order to maintain statistical power. 

5. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > 
Power & Sample Size with Worksheet > One-Way ANOVA. 

6. A graph showing the relationship between Power, Sample Size and Maximum Difference can 
then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart. See Part E 
for an example using the 1 Sample t-Test. 
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Part K – Tests for Equal Variance &  
Welch’s ANOVA 

Bartlett’s Test 

Bartlett’s Test is similar to the 2 sample F-Test (SigmaXL > Statistical Tools > 2 Sample 
Comparison Test) but allows for multiple group comparison of variances (or standard deviations).  
Like the F-Test, Bartlett’s requires that the data from each group be normally distributed but is more 
powerful than Levene’s Test. 

1. Open Delivery Times.xls, click on Sheet 1 tab. 

2. Click SigmaXL > Statistical Tools > Equal Variance Tests > Bartlett. Ensure that the entire 
data table is selected. If not, check “Use Entire Data Table”.  

3. Click Next. Ensure that “Stacked Column Format” is checked.  Select Delivery Time 
Deviation as Y, and Floor as X. 
 
 
 
 
 
 
 
 

4. Click OK.  The results are shown below: 
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5. With the p-value = 0.63 we fail to reject H0; we do not have evidence to show that the group 
variances are unequal (practically speaking we will assume that the variances are equal). 

6. All 10 Anderson-Darling Test P-values are > .05 indicating that all group data are normal.  
Since the assumption of normality is met, Bartlett’s is the appropriate test to use.  If any one 
of the groups have a low p-value for the Normality test, then Levene’s test should be used. 

Levene’s Test 

Levene’s Test for multiple group comparison of variances is less powerful that Bartlett’s Test, but is 
robust to the assumption of normality.  (This is a modification of the original Levene’s Test, 
sometimes referred to as the Browne-Forsythe Test).  

1. Open Customer Data.xls, click on Sheet 1 tab. 

2. Click SigmaXL > Statistical Tools > Equal Variance Tests > Levene.  Ensure that the entire 
data table is selected. If not, check “Use Entire Data Table”.  

3. Click Next. Ensure that “Stacked Column Format” is checked.  Select Responsive to Calls as 
Y, and Customer Type as X. 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  The results are shown below: 
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5. The Levene’s Test p-value of 0.0144 tells us that we reject H0.  At least one pairwise set of 
variances are not equal.  The normality test p-values indicate that all 3 groups have non-
normal data (p-values < .05).  Since Levene’s Test is robust to the assumption of normality, it 
is the correct test for equal variances (rather than Bartlett’s Test). 

6. Now that we have determined that the variances (and standard deviations) are not equal, we 
are presented with a problem if we want to apply classical One-Way ANOVA to test for 
equal group means. ANOVA assumes that the group variances are equal.  A modified 
ANOVA called Welch’s ANOVA can be used as an alternative here. 

Welch’s ANOVA Test 

Welch’s ANOVA is a test for multiple comparison of means.  It is a modified One-Way ANOVA 
that is robust to the assumption of equal variances.  Welch’s ANOVA is an extension of the 2 
sample t-test for means, assuming unequal variance (SigmaXL > Statistical Tools > 2 Sample 
Comparison Tests).  Nonparametric methods could also be used here but they are not as powerful as 
Welch’s ANOVA. 

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet). 

2. Click SigmaXL > Statistical Tools > Equal Variance Tests > Welch’s ANOVA. Ensure that 
the entire data table is selected. If not, check “Use Entire Data Table”.  
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3. Click Next. Ensure that “Stacked Column Format” is checked.  Select Responsive to Calls as 
Y, and Customer Type as X. 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  The results are shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. The p-value for Welch’s ANOVA is 0.0135, therefore we reject H0 and conclude that the 
group means for Responsive to Calls are not equal.  We will explore the relationship between 
Overall Satisfaction and Responsive to Calls later. 
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Part L – Nonparametric Multiple Comparison 

Kruskal-Wallis Test 

The Kruskal-Wallis test is an extension of the Mann-Whitney Rank test, allowing for more than 2 
samples.  It is a nonparametric equivalent to the parametric One-Way ANOVA.  The Null 
Hypothesis is: H0: Median1 = Median2 = … = MedianK. Ha: At least two Medians are different. 

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet). 

2. Click SigmaXL > Statistical Tools > Nonparametric Tests > Kruskal-Wallis Median Test.  
Ensure that the entire data table is selected. If not, check “Use Entire Data Table”.  

3. Click Next. Ensure that “Stacked Column Format” is checked.  Select Overall Satisfaction as 
Y, and Customer Type as X. 
 
 
 
 
 
 
 
 
 

4. Click OK.  The results are shown below: 
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The p-value of 0.0000 tells us that we reject H0.  At least one pairwise set of medians are not 
equal. 
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5. The Kruskal-Wallis Statistic is based on comparing mean ranks for each group versus the 
mean rank for all observations.  The Z value for Customer Type 3 is −1.56, the smallest 
absolute Z-value. This size indicates that the mean rank for Type 3 differed least from the 
mean rank for all observations. The Z value for Customer Type 2 is 4.53, the largest absolute 
Z-value. This size indicates that the mean rank differed most from the mean rank for all 
observations. 
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6. A graphical view of the Overall Satisfaction Median and 95% Confidence Intervals are given 
to complement the Z scores.  The fact that the CI’s for Customer Type 2 do not overlap those 
of Type 1 or 3, clearly shows that Customer Type 2 has a significantly higher median 
satisfaction score.  The overlap of CI’s for Type 1 and 3 shows that the median satisfaction 
scores for 1 and 3 are not significantly different. 

Mood’s Median Test 

Mood’s Median Test is an extension of the One Sample Sign Test, using Chi-Square as the test 
statistic.  Like the Kruskal-Wallis test, Mood's median test can be used to test the equality of 
medians from multiple samples.  It provides a nonparametric alternative to the one-way analysis of 
variance. The Null Hypothesis is: H0: Median1 = Median2 = … = MedianK. Ha: At least two 
Medians are different. 

Mood's median test is more robust to outliers than the Kruskal-Wallis test, but is less powerful in the 
absence of outliers.  You should first look at your data with Boxplots. If there are extreme outliers, 
then Mood’s Median should be used rather than Kruskal-Wallis. 

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet). 

2. Click SigmaXL > Statistical Tools > Nonparametric Tests > Mood’s Median Test.  Ensure 
that the entire data table is selected. If not, check “Use Entire Data Table”.  

3. Click Next. Ensure that “Stacked Column Format” is checked.  Select Overall Satisfaction as 
Y, and Customer Type as X. 
 
 
 
 
 
 
 
 
 

4. Click OK.  The results are shown below: 
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The p-value of 0.0012 tells us that we reject H0.  At least one pairwise set of medians are not 
equal. 
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5. A graphical view of the Overall Satisfaction Median and 95% Confidence Intervals are 
given. This is the same graph provided in the Kruskal-Wallis test report. 
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Part M – Nonparametric Runs Test 

Nonparametric Runs Test for Randomness 

The nonparametric runs test provides a test for randomness or independence. The null hypothesis is 
H0: The data is random (or independent).  The alternative hypothesis is Ha: The data is not random 
(or independent).  Note that this test is also provided as an option in Run Charts (SigmaXL > 
Graphical Tools > Run Chart).  In addition to providing an overall test for randomness, 4 tests are 
performed to detect Clustering, Mixtures, Trends, and Oscillations.  If any of these patterns are 
significant (typically using α = 0.01), we would need to take corrective action before proceeding 
with further statistical analysis. (Note that SigmaXL will highlight any p-values < .05 in red). 

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet). 

2. Click SigmaXL > Statistical Tools > Nonparametric Tests > Runs Test.  Ensure that the 
entire data table is selected. If not, check “Use Entire Data Table”. 

3. Click Next.  Select Overall Satisfaction as Y: 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK. The resulting report is shown: 
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5. With all of the p-values being greater than 0.01, we fail to reject H0, and conclude that the 
data is random (or statistically independent).  Recall from the run chart of this data that there 
were no obvious trends or patterns. 

6. Examples of Clustering, Mixtures, Trends, and Oscillations are given below using the Run 
Chart to illustrate. The data for these examples are given in the file Runs Test Example 
Data.xls. 

a. Clustering appears as a group of points in one area of the chart.  It may indicate 
special cause variation such as sampling or measurement problems. 
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b. Mixtures appear as an absence of data points near the center line.  A mixture may 
indicate a bimodal distribution due to a regular change of shift, machinery, or raw 
materials. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that the p-value for Mixtures = 1 – p-value for Clustering. They are mutually 
exclusive. The p-value for Lack of Randomness = 2 * minimum of (p-value 
Clustering, p-value Mixtures).  
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c. Trends appear as an upward or downward drift in the data and may be due to special 
causes such as tool wear. 
 
 
 
 
 
 
 
 
 

Median: 0.00

-6.60

-4.60

-2.60

-0.60

1.40

3.40

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

Ru
n 

Ch
ar

t -
 T

re
nd

s

126 



SigmaXL: Analyze Phase Tools 

 
 
 
 
 
 
 
 
 

d. Oscillations appear as rapid up/down fluctuations indicating process instability. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that the p-value for Trends = 1 – p-value for Oscillation. They are mutually 
exclusive. 

Median: 2.00

-6.60

-4.60

-2.60

-0.60

1.40

3.40

5.40

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

Ru
n 

C
ar

t -
 O

sc
ill

at
io

h
n

127 



SigmaXL: Analyze Phase Tools 

Part N – Attribute/Discrete Data Tests 

Attribute/Discrete Data Tests 

1. We begin with a scenario where Day Shift is running at 80% Yield and Night Shift has 70% 
Yield.  This data is based on a random sample of 100 units for each Shift, each unit is either 
good or bad.  Question: Is Day shift running differently than Night Shift?  Statistically, we 
call the Null Hypothesis, H0: Proportion P1 = Proportion P2; the alternative hypothesis, Ha 
is: P1≠P2. If the calculated p-value < .05, then we reject the null hypothesis and conclude 
that Day Shift and Night Shift are different.  

2. Click SigmaXL > Templates & Calculators > 2 Proportions Test. 

3. Enter x1 = 80, n1 = 100, x2 = 70, n2 = 100 as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Since the p-value of 0.102 is greater than .05, we fail to reject H0.  We do not have enough 
evidence to show that there is a significant difference between Day Shift and Night shift. 
This does not mean that we have proven that they are the same. In practice however, we 
either assume that they are the same or we collect more data. 

4. Now enter x1 = 160, n1 = 200, x2 = 140, n2 = 200. Note that the p-value is now .021, so we 
reject H0. 
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5. Open the file Attribute Data.xls, ensure that Example 1 Sheet is active.  This data is in Two 
–Way Table format, or pivot table format.  Note that cells B2:D4 have been pre-selected. 

6. Click SigmaXL > Statistical Tools > Chi-Square Test – Two-Way Table Data. Note the 
selection of data includes the Row and Column labels (if we had Row and Column Totals 
these would NOT be selected). 

7. Click Next.  Results: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The p-value matches that of the 2 proportion test.  Since the p-value of 0.1 is greater than .05, 
we fail to reject H0.   
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8. Now click Example 2 Sheet tab.  The Yields have not changed but we have doubled the 
sample size.  Repeat the above analysis.  The resulting output is: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Since the p-value is < .05,  we now reject the Null Hypothesis, and conclude that Day Shift 
and Night Shift are significantly different.  The Residuals tell us that Day Shift failures are 
less than expected (assuming equal proportions), and Night Shift failures are more than 
expected. 
 
Note, by doubling the sample size, we improved the power or sensitivity of the test. 
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9. Click the Example 3 Sheet tab.  In this scenario we have 3 suppliers, and an additional 
marginal level. A random sample of 100 units per supplier is tested. The null hypothesis here 
is: No relationship between Suppliers and Pass/Fail/Marginal rates, but in this case we can 
state it as No difference across suppliers.  Redoing the above analysis (for selection B2:E5) 
yields the following: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The p-value tells us that we do not have enough evidence to show that there is a difference 
across the 3 suppliers. 
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10. Click the Example 4 Sheet tab.  Here we have doubled the sample size to 200 per supplier. 
Note that the percentages are identical to example 3. Redoing the above analysis yields the 
following: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
With the p-value < .05 we now conclude that there is a significant difference across 
suppliers.  Examining the residuals tells us that Supplier A has fewer failures than expected 
(if there was no difference across suppliers) and Supplier C has  more failures than expected.  
Supplier B has more marginal than expected and Supplier C has fewer marginal parts than 
expected.  
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11. Open Customer Data.xls. Click Sheet 1 tab.  The discrete data of interest is Complaints and 
Customer Type, i.e., does the type of complaint differ across customer type?  Formally the 
Null Hypothesis is that there is no relationship (or independence) between Customer Type 
and Complaints. 

12. Click SigmaXL > Statistical Tools > Chi-Square Test. Select Major-Complaint for X1 and 
Customer Type for X2. 
  
 
 
 
 
 
 
 
 

13. Click OK.  Results: 
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Here with the p-value = 0.142 we fail to reject H0, so we do not have enough evidence to 
show a difference in customer complaints across customer types. 
 
Note: If more than 20% of Fitted Cells are Sparse - cells whose expected value is less than 5 
– consider collecting more data, consolidation of levels, or removal of columns.  
 
Tip: Use Chi-Square Analysis to complement Advanced Pareto Analysis. 
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Power & Sample Size for One Proportion Test 

To determine Power & Sample Size for a 1 Proportion Test, you can use the Power & Sample 
Size Calculator or Power & Sample Size with Worksheet.   

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > 1 Proportion Test 
Calculator. 

2. Select “Solve For” Power (1 – Beta).  Enter Sample Size and  Alternative Proportion as 
shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that we are calculating the power or likelihood of detection given that the hypothesized 
proportion is 0.5, but the alternative proportion is 0.6, sample size = 300, significance level = 
.05, and Ha: Not Equal To (two sided test). 

3. Click OK. The resulting report is displayed: 
 
 
 
 
 
 
A power value of 0.94 is acceptable, but note that the sample size n = 300, and the difference 
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in proportion value is 0.1 or 10%!  The sample size requirements for discrete data are much 
higher than those for continuous data. 

4. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > 
Power & Sample Size with Worksheet > 1 Proportion Test. 

5. A graph showing the relationship between Power, Sample Size and Proportion Value can 
then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart. See Part E 
for an example using the 1 Sample t-Test. 
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Power & Sample Size for Two Proportions Test 

To determine Power & Sample Size for a 2 Proportions Test, you can use the Power & Sample 
Size Calculator or Power & Sample Size with Worksheet.   

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > 2 Proportions Test 
Calculator. 

2. Select “Solve For” Power (1 – Beta).  Enter Sample Size and  Proportion 1 values as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that we are calculating the power or likelihood of detection given that P1 = 0.5 and P2 = 
0.6, sample size for each group = 300, significance level = .05, and Ha: Not Equal To (two 
sided test). 

3. Click OK. The resulting report is displayed: 
 
 
 
 
 
 
A power value of 0.69 is unacceptable.  Note that this value is much less than the power for 
the one proportion test (0.94).   
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4. To compensate, we will double the sample size per group. Press F3  or click “Recall 
SigmaXL Dialog” to recall last dialog.  Change the sample size per group from 300 to 600. 
Note that the power value is now 0.94. 

5. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > 
Power & Sample Size with Worksheet > 2 Proportions Test. 

6. A graph showing the relationship between Power, Sample Size and Proportion Values can 
then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart. See Part E 
for an example using the 1 Sample t-Test. 
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Part O – Multi-Vari Charts 

Multi-Vari Charts 

The Multi-Vari chart is a powerful tool to identify dominant Sources of Variation (SOV).  The three 
major “families” of variation are: Within Unit, Between Unit, and Temporal (Over Time).  We will 
look at examples of each type of SOV and then use the Multi-Vari Chart to study Overall 
Satisfaction in the Customer Data.xls file. 

1. Open Within.xls, click Sheet 1. Select SigmaXL > Graphical Tools > Multi-Vari Options 

2. The charts shown will be updated as options are selected. Note that they are for 
demonstration purposes and are not based on the Customer Data.xls data. Ensure that all 
general options are selected (Range Line, Individual Data Points, Min and Max, Standard 
Deviation Chart).  Select Mean Options, ensure that Show Means, Connect Means, and 
Group Means are checked.  Ensure that Save Defaults is checked.  These settings would 
be typical for a Multi-Vari chart. (The Median options provide the ability to display 
percentiles as an alternative to the Means). 
 
 
 
 
 
 
 
 
 
Tip:  Multi-Vari Charts can be used to display Confidence Intervals (as we did earlier in 
Part C).  To do this, check the 95% Confidence Interval. 

3. Click Finish.  SigmaXL automatically starts the Multi-Vari Chart procedure (this is 
equivalent to clicking SigmaXL > Graphical Tools > Multi-Vari Charts). 

4. Check Use Entire Data Table. Click Next. 
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5. Note that the input X’s can be text or numeric but should be discrete.  Y’s must be 
numeric - typically continuous, but can also be count or proportion data.  

6. Select Measurement as the Numeric Response (Y); unit as Group Category (X1) and time 
as Group Category (X2) 
 
 
 
 
 
 
 
 
 
 
 

7. Click OK.  Resulting Multi-Vari Chart illustrating dominant “Within Unit” Source of 
Variation: 
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8. Open Between.xls, click Sheet 1. Select SigmaXL > Graphical Tools > Multi-Vari 
Charts.  Check Use Entire Data Table. Click Next. 

9. Select Measurement as the Numeric Response (Y); unit as Group Category (X1) and time 
as Group Category (X2). 
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10. Click OK.  Resulting Multi-Vari Chart illustrating dominant “Between Unit” Source of 
Variation: 
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11. Open OverTime.xls, click Sheet 1. Select SigmaXL > Graphical Tools > Multi-Vari 
Charts.  Check Use Entire Data Table. Click Next. 

12. Select Measurement as the Numeric Response (Y); unit as Group Category (X1) and time 
as Group Category (X2). 

13. Click OK.  Resulting Multi-Vari Chart illustrating dominant “Over Time” Source of 
Variation: 
 
 
 
 
 
 
 
 
 
 
 
 
 
.   

85

90

95

100

105

110

115

U1 U2 U3

unit - time: # 1

M
ea

su
re

m
en

t  
(M

ea
n 

O
pt

io
ns

)

0.00

0.20

0.40

0.60
0.80

1.00

1.20

1.40

U1 U2 U3

unit - time: # 1

St
an

da
rd

 D
ev

ia
tio

n

85

90

95

100

105

110

115

U1 U2 U3

unit - time: # 2

0.00

0.20

0.40

0.60
0.80

1.00

1.20

1.40

U1 U2 U3

unit - time: # 2

85

90

95

100

105

110

115

U1 U2 U3

unit - time: # 3

0.00

0.20

0.40

0.60
0.80

1.00

1.20

1.40

U1 U2 U3

unit - time: # 3

141 



SigmaXL: Analyze Phase Tools 

14. Open Customer Data.xls, click Sheet 1. Select SigmaXL > Graphical Tools > Multi-
Vari Charts 

15. Select Overall Satisfaction as Y; Customer Type as X1; Size of Customer as X2; Product 
Type as X3. 
 
 
 
 
 
 
 
 
 
 

16. Click OK. Resulting Multi-Vari chart: 
 
 
 
 
 
 
 
 
 
 
 
 
 
Examining this Multi-Vari chart reveals that the dominant Source of Variation is “within” 
Customer Type, followed by “between” Customer Type. Furthermore, it would be 
worthwhile to examine the combination of Customer Type 2, Customer Size Large, and 
Product Type Consumer. 
 
Other tools that can help us identify potential X factors that may explain some of the 
large “Within” variability are the Scatter Plot, Scatter Plot Matrix and Correlation Matrix. 
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Part P – Scatter Plots 

Scatter Plots 

1. Open Customer Data.xls. Click Sheet 1 Tab. Click SigmaXL > Graphical Tools > Scatter 
Plots; if necessary, click Use Entire Data Table, click Next. 

2. Select Overall Satisfaction as Y, Avg Days Order Time to Delivery as X1. 
 
 
 
 
 
 
 
 
 

3. Click OK. The resulting Scatter Plot is shown with equation, trendline, 95% confidence 
interval (blue lines – for a given X value this is the 95% confidence interval for predicted 
mean Overall Satisfaction) and 95% prediction interval (red lines – for a given X value this is 
the 95% confidence interval for predicted individual values of Overall Satisfaction). 
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The equation is based on linear regression, using the method of least squares.   R-squared * 100 
is the percent variation of Y explained by X (here 10.3%). 

4. Now we want to redo the Scatter Plot and stratify by Customer Type. Press F3  or click 
“Recall SigmaXL Dialog” to recall last dialog. (or Click Sheet 1 Tab; Click SigmaXL > 
Graphical Tools > Scatter Plots; click Next). 

5. Select Overall Satisfaction as Y, Average Days Order Time to Delivery as X1; Customer 
Type as X2, Uncheck 95% Confidence Interval and 95% Prediction Interval. Click OK. 
Resulting Scatter Plots are shown (with formulas moved and resized): 
 
 
 
 
 
 
 
Clearly, according to the analysis, Customer Type 3 is happier if orders take longer!  But, 
does this make sense? Of course not! Customer Sat scores should not increase with Order to 
Delivery time. What is happening here? This is a coincidental situation. Something else is 
driving customer satisfaction.  We will now look at the Scatter Plot Matrix to help us 
investigate other factors influencing Customer Satisfaction. 
 
Tip: Be careful when interpreting scatter plots (and other statistical tools): Y versus X 
correlation or statistical significance does not always mean that we have a causal 
relationship.  Umbrella sales are highly correlated to traffic accidents, but we cannot reduce 
the rate of traffic accidents by purchasing fewer umbrellas!  The best way to validate a 
relationship is to perform a Design of Experiments (see Improve Phase).   
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Scatter Plot Matrix 

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet).  Click 
SigmaXL > Graphical Tools > Scatter Plot Matrix.  

2. Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

3. Select the variable “Avg No of orders per month”; shift-click on “Staff Knowledge” and 
click Numeric Data Variables (Y) as shown: 
 
 
 
 
 

4.  Click OK. Resulting Scatter Plot Matrix: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Of particular interest is Overall Satisfaction versus Responsiveness to Calls and Ease of 
Communications. These will be explored further with Multiple Linear Regression. 
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Part Q – Correlation Matrix 

The correlation matrix complements the scatterplot matrix by quantifying the degree of association.  
The following table shows the approximate relationship between r, R-squared, and degree of 
association: 
 

Pearson Correlation Coefficient 
(r)  

R-Squared (%) Degree of association 

0.9 <= |r| <=1 > 80 % Strong 

0.7 <= |r| < 0.9 50 % to 80 % Moderate 

|r| < 0.7 < 50 % Weak 

Pearson Probability, p > 0.05  None 

Correlation Matrix 

1. Open Customer Data.xls. Click Sheet 1 tab (or press F4 to activate last worksheet).  Click 
SigmaXL > Statistical Tools > Correlation Matrix. Ensure that entire data table is selected. If 
not, check “Use Entire Data Table”. Click Next. 

2. Select the variable “Avg No of orders per month”; shift-click on “Staff Knowledge” and click 
Numeric Data Variables (Y) as shown: 
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3. Click OK.  Resulting Correlation Matrix is shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Correlations highlighted in red are considered significant (p-values < .05).  The corresponding 
correlation coefficients above the p-values are also highlighted in red.  (Compare these to the 
Scatterplot Matrix). 
Note that Spearman’s Rank Correlation complements Pearson’s Correlation, in that it provides a 
robust measure of association.  Spearman’s rank is based on correlated ranks, which are not 
sensitive to outliers. 
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Part R – Multiple Regression 

Multiple Regression 

Multiple Regression analyzes the relationship between one dependent variable (Y) and multiple 
independent variables (X's).  It is used to discover the relationship between the variables and create 
an empirical equation of the form:  

Y = b0 + b1*X1 + b2*X2 + ... + bn*Xn 

This equation can be used to predict a Y value for a given set of input X values.  SigmaXL uses the 
method of least squares to solve for the model coefficients and constant term.  Statistical tests of 
hypothesis are provided for the model coefficients.   

1. Open Customer Data.xls. Click Sheet 1 Tab (or press F4 to activate last worksheet). Click 
SigmaXL > Statistical Tools > Regression > Multiple Regression; if necessary, click Use Entire 
Data Table, click Next. 

2. Select Overall Satisfaction as the Response (Y), select Responsive to Calls and Ease of 
Communications as the Predictors (X’s).  
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3. Click OK. Resulting Multiple Regression report is shown: 
 
 
 
 
 
 
 
 
 
 
 
 
This model of Overall Satisfaction as a function of Responsiveness to Calls and Ease of 
Communications looks very good with an R-Square value of 90%.  Both Predictors are shown to 
be significant with their respective p-values < .05.  Clearly we need to focus on these two X 
factors to improve customer satisfaction. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

149 



SigmaXL: Analyze Phase Tools 

4. The Residual Plots are shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Residuals are the unexplained variation from the regression model (Y - Y-hat).  We expect to see 
the residuals normally distributed with no obvious patterns in the above graphs. Clearly this is 
not the case here, with the Residuals versus Predicted Values indicating there is likely some 
other X factor influencing the Overall Satisfaction.  It would be appropriate to consider other 
factors in the model but we will not pursue this further. 
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Part S – Logistic Regression 

Binary Logistic Regression 

Binary Logistic Regression is used to analyze the relationship between one binary dependent 
variable (Y) and multiple independent numeric and/or discrete variables (X's).  It is used to discover 
the relationship between the variables and create an empirical equation of the form:  

Ln(Py/(1-Py)) = b0 + b1*X1 + b2*X2 + ... + bn*Xn 

This equation can be used to predict an event probability Y value for a given set of input X values.  
SigmaXL uses the method of maximum likelihood to solve for the model coefficients and constant 
term.  Statistical tests of hypothesis and odds-ratios are provided for the model coefficients.  The 
odds-ratios identify change in likelihood of the event for one unit change in X. 

An example application from medical research would be Y=Disease (Yes/No) and X’s = Age, 
Smoker (Yes/No), Number Years of Smoking and Weight.  The model coefficient p-values would 
indicate which X’s are significant and the odds-ratios would provide the relative change in risk for 
each unit change in X. 

We will analyze the familiar Customer Satisfaction data using Y=Discrete Satisfaction where the 
values have been coded such that an Overall Satisfaction score >= 3.5 is considered a 1, and scores < 
3.5 are considered a 0. Please note, we are not advising that continuous data be converted to discrete 
data in actual practice, but simply using the Discrete Satisfaction score for continuity with the 
previous analysis. 

1. Open Customer Data.xls. Click Sheet 1 Tab (or press F4 to activate last worksheet). Click 
SigmaXL > Statistical Tools > Regression > Binary Logistic Regression; if necessary, click Use 
Entire Data Table, click Next. 

2. Select Sat-Discrete as the ‘Response (Y)’, select Responsive to Calls and Ease of 
Communications as ‘Continuous Predictors (X)’ and Customer Type for ‘Categorical Predictors 
(X)’. 
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Note that Response Count (Y)/Sample Size (Trials) should be used when each record contains 
both the number of occurrences along with associated sample size. This is common when 
tracking daily quality data or performing design of experiments where each run contains a 
response of the number of defects and sample size. 

3. Click OK.  The resulting Binary Logistic report is shown: 
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4. The Likelihood Ratio p-value < .05 tells us that the model is significant.  The p-values for the 
coefficients in the Parameter Estimates table confirm that Responsive to Calls and Ease of 
Communications are significant.  

5. The p-value in Wald Estimates for Categorical (Discrete) Predictors table tells us that Customer 
Type is not significant here.  
Tip: Significance for categorical predictors should be based on the Wald Estimates not the p-
values given in the Parameter Estimates table. 

6. Note that Customer Type 1 is not displayed in the Parameter Estimates table.  This is the 
“hidden” reference value for Customer Type. Categorical predictors must have one level selected 
as a reference value. SigmaXL sorts the levels alphanumerically and selects the first level as the 
reference value. 

7. Now we will rerun the binary logistic regression but remove Customer Type as a predictor.  
Press F3  or click “Recall SigmaXL Dialog” to recall last dialog.  Remove Customer Type by 
highlighting Customer Type and double-clicking (or press the Remove button). 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click Ok. The resulting Binary Logistic report is shown: 
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9. The Odds Ratios in the Parameter Estimates table tell us that for every unit increase in 
Responsive to Calls we are 11.7 times more likely to obtain a satisfied customer.  For every unit 
increase in Ease of Communications we are 13.3 times more likely to obtain a satisfied customer. 

10. McFadden’s Pseudo R-Square mimics the R-square found in linear regression. This value varies 
between 0 and 1 but is typically much lower than the traditional R-squared value. A value less 
than 0.2 indicates a weak relationship; 0.2 to 0.4 indicates a moderate relationship; greater than 
0.4 indicates a strong relationship.   Here we have an R-square value of 0.66 indicating a strong 
relationship.  This is also confirmed with the  Percent Correctly Predicted value of 96%. 

11. The Pearson, Deviance and Hosmer-Lemeshow Goodness of Fit tests are used to confirm if the 
binary logit model fits the data well. P-values < .05 for any of these tests indicate a significant 
lack of fit.  Here the Hosmer-Lemeshow test is indicating lack of fit. Residuals analysis will help 
us to see where the model does not fit the data well. 

12. The measures of association are used to indicate the relationship between the observed responses 
and the predicted probabilities. Larger values for Goodman-Kruskal Gamma, Somers’ D and 
Kendall’s Tau-a indicate that the model has better predictive ability. 

13. The residuals report is given on the Sheet Binary Logistic Residuals.  Three types of residuals 
are provided: Pearson, Standardized Pearson and Deviance.  The Standardized Pearson Residual 
is most commonly used and is shown here plotted on a Run Chart: 
 
 
 
 
 
 
 
 
 
Any Standardized Pearson Residual value that is less than -3 or greater than +3 are considered 
extreme and should be investigated.  There are 3 such outliers here: rows 24, 67, and 77 in the 
residuals table.  The +3.4 value indicates that the predicted event probability was low (.08) but 
the actual result was a 1.  The -6.6 value indicates that the predicted event probability was high 
(.98) but the actual result was a 0.  The large negative residuals have high Responsive to Calls 
and Ease of Communications but dissatisfied customers.  The reasons for these discrepancies 
should be explored further but we will not do so here. 
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14. Reselect the Binary Logistic report sheet.  Scroll over to display the event probability calculator: 
 
 
 
 
 
This calculator provides a predicted event probability for given values of X (in this case the 
probability of a satisfied customer).  Enter the values 3,3; 4,4; 5,5 as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If Responsive to Calls and Ease of Communications are both equal to 3, the probability of a 
satisfied customer is only .07 (7%); if Responsive to Calls and Ease of Communications are both 
equal to 5, the probability of a satisfied customer is .9995 (99.95%) 

15. Note that if the calculator includes predictors that are categorical (discrete), enter a 0 or 1 to 
denote the selected level as shown below (using the original analysis which included Customer 
Type): 
 
 
 
 
 
 
If we wanted to select Customer Type 1, enter a 0 for both Customer Types 2 and 3.  Customer 
Type 1 is the hidden reference value. 
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Ordinal Logistic Regression 

Ordinal Logistic Regression is used to analyze the relationship between one ordinal dependent 
variable (Y) and multiple independent continuous and/or discrete variables (X's). 

We will analyze the Customer Satisfaction data using Y=Loyalty –Likely to Recommend Score 
which contains ordinal integer values from 1 to 5, where 5 indicates that the customer is very likely 
to recommend us and a 1 indicating that they are very likely to not recommend us. 

1. Open Customer Data.xls. Click Sheet 1 Tab (or press F4 to activate last worksheet). Click 
SigmaXL > Statistical Tools > Regression > Ordinal Logistic Regression; if necessary, click Use 
Entire Data Table, click Next. 

2. Select Loyalty – Likely to Recommend as the Response (Y), select Responsive to Calls and Ease 
of Communications as the Continuous Predictors (X’s).  
 
 
 
 
 
 
 
 
 
 
 
 

3. Click OK. The resulting Ordinal Logistic report is shown: 
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4. The Likelihood Ratio p-value < .05 tells us that the model is significant.  The low p-values for 
the coefficients confirm that Responsive to Calls and Ease of Communications are significant. 

5. The Odds Ratios tell us that for every one-unit increase in Responsive to Calls the chance of a 
Loyalty score of 1 versus 2  (or 2 versus 3, etc.) is reduced by a multiple of 0.36. This is not very 
intuitive but will be easy to see when we use the Response Outcome Probability calculator. 

6. McFadden’s Pseudo R-Square value is 0.185 indicating that this is a weak (but close to 
moderate) degree of association.  This is also confirmed with the  Percent Correctly Predicted 
value of 48%. 
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7. The Pearson and Deviance Goodness of Fit (GOF) tests are used to confirm if the ordinal logit 
model fits the data well. P-values < .05 would indicate a significant lack of fit.  Given that the 
GOF p-values are greater than .05, we conclude that there is no significant lack of fit. 

8. Scroll across to the Response Outcome Probability calculator. This calculator provides predicted 
outcome (event) probabilities for given values of X (in this case the probability of a satisfied 
customer).  Enter the values 3,3; 4,4; 5,5 as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9. Referring to the Predicted Probability for each Level, if Responsive to Calls and Ease of 
Communications are both equal to 3, we would expect to see typical loyalty scores of 3 (57%) 
with some at 2 (20%) and 4 (20%);  if Responsive to Calls and Ease of Communications are both 
equal to 5, we would expect typical loyalty scores of 4 (53 %) with some at 3 (34%) and 5 (9%). 
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Part A – Overview of Basic Design of 
Experiments (DOE) Templates 

The DOE templates are similar to the other SigmaXL templates: simply enter the inputs and 
resulting outputs are produced immediately.  The DOE templates provide common 2-level designs 
for 2 to 5 factors.  (Currently these templates do not allow the addition of center-points).  

Click SigmaXL > Basic DOE Templates to access these templates: 

• Two-Factor, 4-Run, Full-Factorial 

• Three-Factor, 4-Run, Half-Fraction, Res III 

• Three-Factor, 8-Run, Full-Factorial 

• Four-Factor, 8-Run, Half-Fraction, Res IV 

• Four-Factor, 16-Run, Full-Factorial 

• Five-Factor, 8-Run, Quarter-Fraction, Res III 

• Five-Factor, 16-Run, Half-Fraction, Res V 

After entering the template data, main effects and interaction plots may be created by clicking 
SigmaXL > Basic DOE Templates > Main Effects & Interaction Plots.  The DOE template must be 
the active worksheet. 

DOE Templates are protected worksheets by default, but this may be modified by clicking Tools > 
Protection > Unprotect Sheet. 

Advanced analysis is available, but this requires that you unprotect the DOE worksheet.  The 
following example shows how to use Excel’s Equation Solver and SigmaXL’s Multiple Regression 
in conjunction with a DOE template. 

Caution: If you unprotect the worksheet do not change the worksheet title (e.g. Three-Factor, 
Two-Level, 8-Run, Full-Factorial Design of Experiments).  This title is used by the Main Effects 
& Interaction Plots to determine appropriate analysis.  Also, do not modify any cells with formulas. 



SigmaXL: Improve Phase Tools: DOE 

Part B – Three Factor Full Factorial Example 

1. Open the file DOE Example - Robust Cake.xls.  This is a Robust Cake Experiment adapted 
from the Video "Designing Industrial Experiments", by Box, Bisgaard and Fung. 

2. The response is Taste Score (on a scale of 1-7 where 1 is "awful" and 7 is "delicious"). 

3. The five Outer Array Reps have different Cooking Time and Temperature Conditions. 

4. The goal is to Maximize Mean and Minimize StDev of the Taste Score. 

5. The X factors are Flour, Butter, and Egg.  Actual low and high settings are not given in the 
video, so we will use coded -1 and +1 values.  We are looking for a combination of Flour, 
Butter, and Egg that will not only taste good, but consistently taste good over a wide range of 
Cooking Time and Temperature conditions. 

6. Scroll down to view the Pareto of Abs. Coefficients for Average (Y). 
 
 
 
 
 
 
 
 
 
 
 
 
 

Pareto of Coefficients for Average (Y)
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7. The BC (Butter * Egg) interaction is clearly the dominant factor.  The bars above the 95% 
confidence blue line indicate the factors that are statistically significant; in this case only BC 
is significant.  Keep in mind that this is an initial analysis.  Later, we will show how to do a 
more powerful Multiple Regression analysis on this data.  (Also the Rule of Hierarchy states 
that if an interaction is significant, we must include the main effects in the model used). 
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8. The significant BC interaction is also highlighted in red in the table of Effects and 
Coefficients: 
 
 
 
 
 
 
 

Calculation of Effects and Coefficients for Average (Y):

Constant BC

-1.245
4.6825 -0.6225

9.6928E-20 0.01161

A B C AB AC ABC
Avg(Avg(Y)) @ +1: 4.865 4.79 5.125 4.74 4.755 4.06 4.62
Avg(Avg(Y)) @ -1: 4.5 4.575 4.24 4.625 4.61 5.305 4.745
Effect (Delta): 0.365 0.215 0.885 0.115 0.145 -0.125
Coefficient (Delta/2): 0.1825 0.1075 0.4425 0.0575 0.0725 -0.0625
SE Coefficient: 0.2325 0.2325 0.2325 0.2325 0.2325 0.2325 0.2325 0.2325
T-value 20.1397849 0.7849 0.4624 1.9032 0.24731 0.31183 -2.6774 -0.2688
P-value 0.4383 0.6469 0.066 0.80625 0.75719 0.7898

9. The R-Square value is given as 27%.  This is very poor for a Designed Experiment. Typically 
we would like to see a minimum of 50%, with > 80% desirable. 
 
 
 
 
The reason for the poor R-square value is the wide range of values over the Cooking 
Temperature and Time conditions.  In a robust experiment like this, it is more appropriate to 
analyze the mean response as an individual value rather than as five replicate values.  The 
Standard Deviation as a separate response will also be of interest. 

R-Square: 27.03%
R-Square Adj.: 11.06%
S 1.4705

10. If the Responses are replicated, SigmaXL draws the blue line on the Pareto Chart using an 
estimate of experimental error from the replicates. If there are no replicates, an estimate 
called Lenth’s Pseudo Standard Error is used. 

11. If the 95% Confidence line for coefficients were to be drawn using Lenth’s method, the value 
would be 0.409 as given in the table: 
 
 
 
 
 
This would show factor C as significant. 
 
 
 

Lenth's Pseudo Standard Error (PSE) Analysis for Unreplicated Data:

Lenth's PSE for Coefficients: 0.10875
Length's Margin of Error for Coefficients (95% Conf. Level): 0.40935
Length's Margin of Error for Effects (95% Conf. Level): 0.8187
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12. Scroll down to view the Pareto of Coefficients for StdDev(Y).   
 
 
 
 
 
 
 
 
 
 
 
 

Pareto of Coefficients for StdDev (Y)

0

0.1

0.2

0.3

0.4

0.5

0.6

0.7

0.8

A BC C B ABC AC AB

Ab
s(

Co
ef

fic
ie

nt
s)

13. The A (Flour) main effect is clearly the dominant factor, but it does not initially appear to be 
statistically significant (based on Lenth’s method).  Later, we will show how to do a more 
powerful Regression analysis on this data. 

14. The Pareto chart is a powerful tool to display the relative importance of the main effects and 
interactions, but it does not tell us about the direction of influence.  To see this, we must look 
at the main effects and interaction plots.  Click SigmaXL > Basic DOE Templates > Main 
Effects & Interaction Plots.  The resulting plots are shown below: 
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Main Effects Plots for Avg(Avg(Y))
Response: Taste Score (Scale 1-7 where 1 is "awful" and 7 is "delicious"); Outer Array Reps have different Cooking Time and Temp Conditions
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Interaction Plots for Avg(Avg(Y)):
Response: Taste Score (Scale 1-7 where 1 is "awful" and 7 is "delicious"); Outer Array Reps have different Cooking Time and Temp Conditions
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Main Effects Plots for StdDev (Y):
Response: Taste Score (Scale 1-7 where 1 is "awful" and 7 is "delicious"); Outer Array Reps have different Cooking Time and Temp Conditions
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15. The Butter*Egg two-factor interaction is very prominent here.  Looking at only the Main 
Effects plots would lead us to conclude that the optimum settings to maximize the average 
taste score would be Butter = +1, and Egg = +1, but the interaction plot tells a very different 
story.  The correct optimum settings to maximize the taste score is Butter = -1 and Egg = +1. 

16. Since Flour was the most prominent factor in the Standard Deviation Pareto, looking at the 
Main Effects plots for StdDev, we would set Flour = +1 to minimize the variability in taste 
scores.  The significance of this result will be demonstrated using Regression analysis. 
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17. Click on the Sheet Three-Factor 8-Run DOE. At the Predicted Output for Y, enter Flour = 
1, Butter = -1, Egg = 1 as shown: 
 
 
 
 
 
 
 
 
The predicted average (Y-hat) taste score is 5.9 with a predicted standard deviation (S-hat) of 
0.68.  Note that this prediction equation includes all main effects, two-way interaction, and 
the three-way interaction. 
 

Multiple Regression and Excel Solver (Advanced Topics): 

18. In order to run Multiple Regression analysis we will need to unprotect the worksheet.  Click 
Tools > Protection > Unprotect Sheet. 

19. In the Coded Design Matrix, highlight columns A to ABC, and the calculated responses as 
shown: 
 
 
 
 
 
 
 

20. Click SigmaXL > Statistical Tools > Regression > Multiple Regression. Click Next. 
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21. Select Average (Y) as the Response (Y); holding the CTRL key, select B, C, and BC; click 
Predictors (X) as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

22. Click OK. The resulting regression report is shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that the R-square value of 92.85% is much higher than the earlier result of 27%.  This is 
due to our modeling the mean response value rather than considering all data in the outer 
array.  Note also that the C main effect now appears as significant. 
 

The Regression Equation is: Average (Y) = (4.6825) + (0.1075) * B + (0.4425) * C + (-0.6225) * BC

Model Summary
R-Sq 92.85%
R-Sq (adj) 87.50%
S 0.302572

Analysis of Variance
Source DF SS MS F P
Model 3 4.75895 1.586317 17.3273257 0.009341
Error 4 0.3662 0.09155
Total 7 5.12515

Predictor Coef SE Coef T P
Constant 4.6825 0.106975 43.77172
B 0.1075 0.106975 1.004903 0.371801
C 0.4425 0.106975 4.136463
BC -0.6225 0.106975 -5.819091

1.6288E-06

0.01441791
0.00434233
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23. Click on the Sheet Three-Factor 8-Run DOE.   

24. With the Coded Design Matrix highlighted as before, click SigmaXL > Statistical Tools > 
Regression > Multiple Regression. Click Next. 

25. Select StdDev (Y) as the Response (Y); select A for Predictors (X) as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 

26. Click OK.  Resulting regression report is shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that Factor A (Flour) now shows as a statistically significant factor affecting the 
Standard Deviation of Taste Score. 
 

The Regression Equation is: StdDev (Y) = (1.358077) + (-0.4423) * A

Model Summary
R-Sq 61.54%
R-Sq (adj) 55.13%
S 0.403733

Analysis of Variance
Source DF SS MS F P
Model 1 1.565009 1.565009 9.601252189 0.021155

7.68829E-05
0.021154543

Error 6 0.978003 0.163
Total 7 2.543011

Predictor Coef SE Coef T P
Constant 1.358077 0.142741 9.51426
A -0.442296 0.142741 -3.098589
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27. Now we will use Excel’s Equation Solver to verify the optimum settings determined using 
the Main Effects and Interaction Plots. 

28. Click on the Sheet Three-Factor 8-Run DOE.  At the Predicted Output for Y, enter 1 for 
Flour.  We are setting this as a constraint, because Flour = +1 minimizes the Standard 
Deviation.  Reset the Butter and Egg to 0 as shown: 
 
 
 
 
 
 

29. Click Tools > Add-Ins. Ensure that the Solver Add-in is checked.  If the Solver Add-in does 
not appear in the Add-ins available list, you will need to re-install Excel to include all add-
ins.  
 
 
 
 
 
 
 
 
 

30. Click OK.  Click Tools > Solver.  Set the Solver Parameters as shown: 
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Cell J11 is the Y-hat, predicted average taste score. Solver will try to maximize this value.  
Cells H11 to H13 are the Actual Factor Settings to be changed.  Cells I11 to I13 are the 
Coded Factor settings where the following constraints are given: I11=1; I12 >= -1; I12 <= 1; 
I13 >= -1; I13 <=1. 
 

31. Click Solve.  The solver results are given in the Predicted Output for Y as Butter = -1 and 
Egg = 1. 
 
 
 
 
 
 
 
 

32. Solver indicates that a solution is found: 
 
 
 
 
 
 
 
 

33. Click OK to keep the solution.
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Part A - Individuals Charts 

Individuals Charts 

1. Open Customer Data.xls, click on Sheet 1.  Click SigmaXL > Control Charts > Individuals. 
Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

2. Select Overall Satisfaction as Y, ensure that Calculate Limits is selected. 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.  Click OK. Resulting Individuals control chart: 
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4. We have seen this data earlier as a run chart.  The Control Chart adds calculated control 
limits.  Note that the Upper Control Limit exceeds the survey upper limit of 5.  Here it would 
be appropriate to change the UCL to 5.0.  Click “Recall SigmaXL Dialog” menu or press F3 
to recall last dialog. 

5. Select Overall Satisfaction as Y, select Historical Limits, change UCL to 5. 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Click OK. Resulting Individuals chart with modified UCL: 
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7. Open Delivery Times.xls. Click Sheet 1 Tab.  This data set contains room service delivery 
time deviations in minutes.  The Critical Customer Requirement is target time +/- 10 
minutes. 

8. Click SigmaXL > Control Charts > Individuals. Ensure that entire data table is selected. If 
not, check “Use Entire Data Table”. Click Next. 

9. Select Delivery Time Deviation as Y, check Process Capability Report, specify USL = 10, 
Target = 0, LSL = -10 
 
 
 
 
 
 
 
 

10.  Click OK, check Tests for Special Causes, ensure that Calculate Limits is checked. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

11. Click OK. Resulting chart: 
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Some tests for special causes are indicated on the chart.  If more than one test fails, the 
number corresponds to the first failed test. 
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12.  There are no points that exceed the +/- 3 sigma limits on this chart, but we see some 
indication of instability with tests for special causes.  Clicking on the Indiv Tests Tab gives 
us a detailed report.: 
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13. These tests for special causes can have defaults set to apply any or all of Tests 1-8.  Test 2 
can be set to 7, 8, or 9 points in a row on same side of CL. Click SigmaXL > Control Charts 
> “Tests for Special Causes” Defaults to run selected tests for special causes:  
 
 
 
 
 
 
 
 
 
 
Note that these defaults will apply to Individuals and X-bar charts.  Test 1 to 4 settings will 
be applied to Attribute Charts. 

14. Click on Indiv Proc Cap Tab to view the Process Capability Report, which includes potential 
(short term) capability indices Cp and Cpk: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



SigmaXL: Control Phase Tools: SPC 

15. While this process demonstrated some slight instability on the control charts, the bigger issue 
was being late 6 minutes on average and having a Standard Deviation of 7.2 minutes!  One 
improvement implemented was rescheduling the service elevators so that Room Service and 
Maintenance were not both trying to use them during peak times. 

16. Click on the Indiv sheet.  With 725 data points, you may want to have a closer look at the 
most recent data.  To do this, click SigmaXL Chart Tools > Show Last 30 Points. (If this 
menu item does not appear, click on any cell adjacent to the chart).   The resulting chart is 
shown: 
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17. To reset the chart, click SigmaXL Chart Tools > Show All Data Points. 
 

Individuals Charts: Advanced Limit Options – Historical Groups 

1. Open Catapult Data Before After Improvement.xls. Click Sheet 1 Tab.  This data set 
contains Catapult firing distances. Before_After denotes before improvement and after 
improvement. The target distance is 100 inches with the goal being to hit the target and 
minimize variation about the target.  We would like to use an individuals control chart with 
historical groups to split the limits demonstrating the before versus after improvement. 

2. Click SigmaXL > Control Charts > Individuals. Ensure that entire data table is selected. If 
not, check “Use Entire Data Table”. Click Next. 

3. Select Distance as the Numeric Data Variable (Y).  Select Operator for Optional X-Axis 
Labels.  
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4. Click Advanced Limit Options.  Select Specify Historical Groups.  Select Before_After for 
Historical Groups. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note: Process Capability analysis is not permitted when Historical Groups are used.  

5. Click OK. The resulting Individuals Control Chart with split limits based on historical groups 
is shown, demonstrating a clear process improvement: 
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Individuals Charts for Non-Normal Data  
(Box-Cox Transformation)  
 

An important assumption for Individuals Charts is that the data be normally distributed (unlike the 
X-Bar Chart which is robust to non-normality due to the central limit theorem).  If the data is non-
normal, the Box-Cox Transformation tool can be used to convert non-normal data to normal by 
applying a power transformation. 

1. Open the file Non-Normal Cycle Time.xls.  This contains continuous non-normal data of 
process cycle times.  We performed a Process Capability study with this data earlier in the 
Measure Phase, Part H. 

2. Initially we will ignore the non-normality in the data and construct an Individuals Chart.   
Click SigmaXL > Control Charts > Individuals. Ensure that entire data table is selected. If 
not, check “Use Entire Data Table”. Click Next. 

3. Select Cycle Time (Minutes) as the Numeric Data Variable (Y).  Select Calculate Limits. 
Check Tests for Special Causes. 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. The resulting Individuals Chart is shown: 
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5. This chart clearly shows that the process is “out-of-control”.  But is it really?  Non-normality 
can cause serious errors in the calculation of individual chart control limits triggering false 
alarms (Type I errors) or misses (Type II errors). 

6. Select Sheet 1 (or press F4). Click SigmaXL > Control Charts > Box-Cox Transformation. 
Ensure that entire data table is selected. If not, check “Use Entire Data Table”. Click Next. 

7. Select Cycle Time (Minutes) as the Numeric Data Variable (Y) 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  The resulting Box-Cox Transformation report is shown: 
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9. Select cells G1:G31.  Click SigmaXL > Control Charts > Individuals.  Click Next. Select 
Transformed Data (Ln(Y)) as the Numeric Data Variable (Y).  Check Tests for Special 
Causes. 
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10. Click OK.  The resulting individuals chart is shown: 
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11. Compensating for the non-normality, we see that this is in fact a stable process.  One 
disadvantage of this chart is that the transformed Ln(Y) data is not easy to understand and 
interpret.  One option is to apply the inverse  transformation (=EXP(UCL), =EXP(CL), 
=EXP(LCL)) to the Control Limits above and plot the raw data with the modified limits.  
This allows us to display the original data but has the disadvantage that the Tests for Special 
Causes report cannot be used. Note, if the lambda power transformation is anything other 
than 0 (Ln), then use the following formulas to determine the modified Control Limits: 
=UCL^(1/Lambda) 
=CL^(1/Lambda) 
=LCL^(1/Lambda). 
If Lambda is negative, UCL and LCL will be reversed. 
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Part B - X-Bar & Range Charts 

X-Bar & R Charts 

1. Open the file Catapult Data – Xbar Control Charts.xls. Each operator fires the ball 3 
times.  The target distance is 100 inches. The Upper Specification Limit (USL) is 108 inches. 
The Lower Specification Limit (LSL) is 92 inches. 

2. Select B2:F22, here we will only use the first 20 subgroups to determine the control limits. 

3. Select SigmaXL > Control Charts > X-Bar & R. 

4. Do not check Use Entire Data Table! 
 
 
 
 
 

5. Click Next.  Select Subgroups across Rows, select Shot 1, Shot 2, Shot 3 as the Numeric 
Data Variables (Y). Select Operator as Optional X-axis labels. Check Tests for Special 
Causes as shown: 
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6. Click OK. Resulting X-bar & R charts: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

100.37

93.92

106.81

93

95

99

.40

.40

97.40

.40

101.40

103.40

105.40

Jo
hn

Moe
Sall

y
Sue

David
Jo

hn
Moe

Sall
y

Sue
David

Jo
hn

Moe
Sall

y
Sue

David
Jo

hn
Moe

Sall
y

Sue
David

X
-B

ar
 - 

Sh
ot

 1
 - 

S
ho

t 3

6.30

0.00

16.22

-0.70

30

30

30

30

30

11.30

13.30

15.30

Jo
hn

Moe
Sall

y
Sue

David
Jo

hn
Moe

Sall
y

Sue
David

Jo
hn

Moe
Sall

y
Sue

David
Jo

hn
Moe

Sall
y

Sue
David

R 
- S

ho
t 1

 - 
S

ho
t 3

1.

3.

5.

7.

9.

7. This is currently a stable catapult process.  Subgroups 21 to 25 were added afterwards.  To 
add the “new” data to this chart, click SigmaXL Chart Tools > Add Data as shown: 
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8. Note that the Add Data button does NOT recalculate the control limits.  Once control limits 
are established, they should only be recalculated when a deliberate process change or 
improvement is introduced.  (Control Limits can be recalculated using SigmaXL Chart Tools 
> Recalculate Control Limits, but a warning message “Are you sure that you want to 
recalculate control limits?” is given). 
 

9. The “Tests for Special Causes” report gives us more detail on the recent instability: 
 
 
 
 
 
 
The X-bar chart and “Tests for Special Causes” report clearly shows that process is now out 
of control with an unstable mean. The process must be stopped, and the Out-of-Control 
Action Plan must be followed to determine and fix the root cause.  In this case, the assignable 
cause was a change of rubber band requiring a reset of the pull back angle.  The use of tests 
for special causes gave us an early warning of this at observation number 22. 
  
Note that the Range chart is in-control even though the X-Bar chart is out-of-control. 

10. The tests for special causes can have defaults set to apply any or all of Tests 1-8.  Test 2 can 
be set to 7, 8, or 9 points in a row on same side of CL. Click SigmaXL > Control Charts > 
“Tests for Special Causes” Defaults to run selected tests for special causes. (Note that these 
defaults will apply to Individuals and X-bar charts.  Test 1 to 4 settings will be applied to 
Attribute Charts). 

11. Now we will look at Process Capability Indices for this process.  Click on Sheet 1 (or press 
F4 to activate last worksheet).  Click SigmaXL >  Control Charts > X-Bar & R.  Check “Use 
Entire Data Table”. Click Next. (Alternatively select B2:F27, press F3). 

12. Select Shots 1-3 as Numeric Data Variables (Y).  Select Historical Limits. These are the 
limits calculated with the original 20 subgroups. 

13. Check Process Capability Report.  Enter USL = 108, Target = 100, LSL = 92. 
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14. Click OK. 

15. The resulting dialog box settings are shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

16. Click OK.  Click X-Bar & R – Proc Cap sheet for the Process Capability report: 
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Note the difference between Pp and Cp; Ppk and Cpk. This is due to the process instability.  
If the process was stable, the actual performance indices Pp and Ppk would be closer to the 
Cp and Cpk values. 
 
Tip: Another approach here could have been to select Advanced Limit Options and specify 
Subgroup Numbers 1 to 20 for calculation of the control limits. 
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Part C - P-Charts 

P-Charts 

1. Open New York Daily Cycle Time – Discrete.xls.  This is data from the Sigma Savings and 
Loans company, New York location.  Each day the cycle time (in days) for completed loans 
and leases were recorded.  N indicates the number of loans counted.  A “Fail” was recorded 
if the cycle time exceeded the critical customer requirement of 8 days.  Note that we are not 
recommending that continuous data be converted to discrete data in this manner, but using 
this data to illustrate the use of P charts for Discrete or Attribute data. 

2. Select SigmaXL > Control Charts > P.  Ensure that B3:E23 are selected, click Next. 

3. Select “Fail” as the Numeric Data Variable (Y), “N” as the Subgroup Column (Size).  If we 
had a fixed subgroup size the numerical value of the subgroup size could be entered instead 
of Column N. 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK. Resulting P-Chart: 
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The moving limits are due to the varying sample sizes.  While this P-chart shows stability, a 
much bigger concern is the average 41% failure rate to deliver the loans/leases in 8 days or 
less! 
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Part D – Advanced Charts: I-MR-R/S 

I-MR-R Charts 

If the within-subgroup variability is much smaller than between subgroup, the classical X-bar & 
R (or S) chart will not work, producing numerous (false) alarms.  The correct chart to use, in this 
case, is the I-MR-R (or S) chart.  The subgroup averages are treated as individual values (I-MR) 
and the within subgroup ranges are plotted on the Range chart. 

1. Open Between.xls.  We saw this data previously using Multi-Vari charts. First we will 
incorrectly use the X-bar & R chart, and then apply the correct I-MR-R chart. 

2. Click SigmaXL > Control Charts > X-bar & R.  Check Use Entire Data Table. 

3. Click Next.  Select Stacked Column Format.  Select Measurement as Y; select unit as 
Subgroup Column. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK.  Resulting X-bar & R chart: 
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5. Almost all of the data points in the X-bar chart are out-of-control!  This is due to the small 
within-subgroup variability (the control limits are calculated from the within-subgroup 
variability). 

6. Click Sheet 1.  Select SigmaXL > Control Charts > Advanced Charts > I-MR-R. 

7. Click Next.  Select Stacked Column Format.  Select Measurement as Y; select unit as 
Subgroup Column. 
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8. Click OK.  Resulting I-MR-R chart: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This chart is much cleaner, showing a stable Individuals and Range chart.  The MR chart 
may be trending up, but we would want to collect more data before making this conclusion.  
Typically you want at least 20 (30 preferred) subgroups before calculating final control 
limits. 
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